<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
<link rel="canonical" href="https://www.ghacks.net/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>Add Custom Context Menu items to Windows 11&#039;s File Explorer menu - gHacks Tech News</title>
<meta name="description" content="Custom Context Menu is an open source program for Windows 11 to add custom entries to the Windows 11 File Explorer right-click menu." />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Add Custom Context Menu items to Windows 11&#039;s File Explorer menu - gHacks Tech News" />
<meta property="og:description" content="Custom Context Menu is an open source program for Windows 11 to add custom entries to the Windows 11 File Explorer right-click menu." />
<meta property="og:url" content="https://www.ghacks.net/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/" />
<meta property="og:site_name" content="gHacks Technology News" />
<meta property="article:publisher" content="https://www.facebook.com/ghacksnet" />
<meta property="article:published_time" content="2022-04-25T06:38:50+00:00" />
<meta property="og:image" content="https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu.png" />
<meta property="og:image:width" content="1394" />
<meta property="og:image:height" content="836" />
<meta property="og:image:type" content="image/png" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Martin Brinkmann" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="3 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.ghacks.net/#organization","name":"Ghacks Technology News","url":"https://www.ghacks.net/","sameAs":["https://www.facebook.com/ghacksnet"],"logo":{"@type":"ImageObject","@id":"https://www.ghacks.net/#logo","inLanguage":"en-US","url":"https://www.ghacks.net/wp-content/uploads/2015/03/ghacks-technology-news.jpg","contentUrl":"https://www.ghacks.net/wp-content/uploads/2015/03/ghacks-technology-news.jpg","width":235,"height":51,"caption":"Ghacks Technology News"},"image":{"@id":"https://www.ghacks.net/#logo"}},{"@type":"WebSite","@id":"https://www.ghacks.net/#website","url":"https://www.ghacks.net/","name":"gHacks Technology News","description":"The independent technology news blog","publisher":{"@id":"https://www.ghacks.net/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.ghacks.net/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.ghacks.net/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/#primaryimage","inLanguage":"en-US","url":"https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu.png","contentUrl":"https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu.png","width":1394,"height":836,"caption":"windows 11 custom context menu"},{"@type":"WebPage","@id":"https://www.ghacks.net/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/#webpage","url":"https://www.ghacks.net/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/","name":"Add Custom Context Menu items to Windows 11's File Explorer menu - gHacks Tech News","isPartOf":{"@id":"https://www.ghacks.net/#website"},"primaryImageOfPage":{"@id":"https://www.ghacks.net/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/#primaryimage"},"datePublished":"2022-04-25T06:38:50+00:00","dateModified":"2022-04-25T06:38:50+00:00","description":"Custom Context Menu is an open source program for Windows 11 to add custom entries to the Windows 11 File Explorer right-click menu.","breadcrumb":{"@id":"https://www.ghacks.net/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.ghacks.net/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/"]}]},{"@type":"BreadcrumbList","@id":"https://www.ghacks.net/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.ghacks.net/"},{"@type":"ListItem","position":2,"name":"Windows software","item":"https://www.ghacks.net/category/windows-software/"},{"@type":"ListItem","position":3,"name":"Add Custom Context Menu items to Windows 11's File Explorer menu"}]},{"@type":"Article","@id":"https://www.ghacks.net/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/#article","isPartOf":{"@id":"https://www.ghacks.net/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/#webpage"},"author":{"@id":"https://www.ghacks.net/#/schema/person/eda5915cac4e73b013d1c6f412d1824a"},"headline":"Add Custom Context Menu items to Windows 11's File Explorer menu","datePublished":"2022-04-25T06:38:50+00:00","dateModified":"2022-04-25T06:38:50+00:00","mainEntityOfPage":{"@id":"https://www.ghacks.net/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/#webpage"},"wordCount":439,"commentCount":0,"publisher":{"@id":"https://www.ghacks.net/#organization"},"image":{"@id":"https://www.ghacks.net/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/#primaryimage"},"thumbnailUrl":"https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu.png","articleSection":["Windows software"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.ghacks.net/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/#respond"]}],"copyrightYear":"2022","copyrightHolder":{"@id":"https://www.ghacks.net/#organization"}},{"@type":"Person","@id":"https://www.ghacks.net/#/schema/person/eda5915cac4e73b013d1c6f412d1824a","name":"Martin Brinkmann","description":"Martin Brinkmann is a journalist from Germany who founded Ghacks Technology News Back in 2005. He is passionate about all things tech and knows the Internet and computers like the back of his hand. You can follow Martin on Facebook or Twitter","sameAs":["https://www.ghacks.net/"],"url":"https://www.ghacks.net/author/martin/"}]}</script>

<link rel="alternate" type="application/rss+xml" title="gHacks Technology News &raquo; Feed" href="https://www.ghacks.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="gHacks Technology News &raquo; Comments Feed" href="https://www.ghacks.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="gHacks Technology News &raquo; Add Custom Context Menu items to Windows 11&#039;s File Explorer menu Comments Feed" href="https://www.ghacks.net/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/feed/" />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.ghacks.net/wp-includes/css/dist/block-library/style.min.css?ver=5.8.4' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='wpos-slick-style-css' href='https://www.ghacks.net/wp-content/cache/min/1/wp-content/plugins/ghacks-post-slider/assets/css/slick.css?ver=1644924155' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='wppsac-public-style-css' href='https://www.ghacks.net/wp-content/cache/min/1/wp-content/plugins/ghacks-post-slider/assets/css/recent-post-style.css?ver=1644924155' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='swiper-css-css' href='https://www.ghacks.net/wp-content/cache/min/1/wp-content/plugins/my-custom-functionality-master/assets/css/swiper.min.css?ver=1644924155' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='notix-css' href='https://www.ghacks.net/wp-content/cache/min/1/wp-content/plugins/notix-web-push-notifications/public/css/notix-public.css?ver=1644924155' type='text/css' media='all' />
<style id='responsive-menu-inline-css' type='text/css'>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</style>
<link data-minify="1" rel='stylesheet' id='dashicons-css' href='https://www.ghacks.net/wp-content/cache/min/1/wp-includes/css/dashicons.min.css?ver=1644924155' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='ghacks-style-css' href='https://www.ghacks.net/wp-content/cache/min/1/wp-content/themes/new-ghacks-preview/style.css?ver=1644924155' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='single-css-css' href='https://www.ghacks.net/wp-content/cache/min/1/wp-content/themes/new-ghacks-preview/css/single.css?ver=1644924155' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='tablepress-default-css' href='https://www.ghacks.net/wp-content/cache/min/1/wp-content/tablepress-combined.min.css?ver=1644924155' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-responsive-tables-css' href='https://www.ghacks.net/wp-content/plugins/tablepress-responsive-tables/css/tablepress-responsive.min.css?ver=1.8' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='rating_style-css' href='https://www.ghacks.net/wp-content/cache/min/1/wp-content/plugins/all-in-one-schemaorg-rich-snippets/css/jquery.rating.css?ver=1644924155' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='bsf_style-css' href='https://www.ghacks.net/wp-content/cache/min/1/wp-content/plugins/all-in-one-schemaorg-rich-snippets/css/style.css?ver=1644924155' type='text/css' media='all' />
<script type='text/javascript' src='https://www.ghacks.net/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.ghacks.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js' defer></script>
<script type='text/javascript' src='https://www.ghacks.net/wp-content/plugins/notix-web-push-notifications/public/js/notix-public.js?ver=1.1.1' id='notix-js' defer></script>
<script type='text/javascript' src='https://www.ghacks.net/wp-content/plugins/all-in-one-schemaorg-rich-snippets/js/jquery.rating.min.js' id='jquery_rating-js' defer></script>
<link rel="https://api.w.org/" href="https://www.ghacks.net/wp-json/" /><link rel="alternate" type="application/json" href="https://www.ghacks.net/wp-json/wp/v2/posts/178210" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ghacks.net/xmlrpc.php?rsd" />
<link rel='shortlink' href='https://www.ghacks.net/?p=178210' />
<link rel="alternate" type="application/json+oembed" href="https://www.ghacks.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ghacks.net%2F2022%2F04%2F25%2Fadd-custom-context-menu-items-to-windows-11s-file-explorer-menu%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ghacks.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ghacks.net%2F2022%2F04%2F25%2Fadd-custom-context-menu-items-to-windows-11s-file-explorer-menu%2F&#038;format=xml" />
<script type="text/javascript">var ajaxurl = "https://www.ghacks.net/wp-admin/admin-ajax.php";</script><script src="https://polyfill.io/v2/polyfill.min.js?features=fetch" defer></script>
<script>
var isIE11 = !!window.MSInputMethodContext && !!document.documentMode;
if(!isIE11){
"use strict";

function _instanceof(left, right) { if (right != null && typeof Symbol !== "undefined" && right[Symbol.hasInstance]) { return !!right[Symbol.hasInstance](left); } else { return left instanceof right; } }

function _classCallCheck(instance, Constructor) { if (!_instanceof(instance, Constructor)) { throw new TypeError("Cannot call a class as a function"); } }

function _defineProperties(target, props) { for (var i = 0; i < props.length; i++) { var descriptor = props[i]; descriptor.enumerable = descriptor.enumerable || false; descriptor.configurable = true; if ("value" in descriptor) descriptor.writable = true; Object.defineProperty(target, descriptor.key, descriptor); } }

function _createClass(Constructor, protoProps, staticProps) { if (protoProps) _defineProperties(Constructor.prototype, protoProps); if (staticProps) _defineProperties(Constructor, staticProps); return Constructor; }

var AdBlockerDetector = /*#__PURE__*/function () {
  /**
   * @param {string} staticsBaseUrl
   */
  function AdBlockerDetector(isPlus, staticsBaseUrl) {
    _classCallCheck(this, AdBlockerDetector);

    this._cachedDetection = null;
    this._staticsBaseUrl = staticsBaseUrl;
    if (isPlus) this._url = "".concat(this._staticsBaseUrl, "/statics/px.gif");else this._url = "".concat(this._staticsBaseUrl, "/statics/dfp.js");
  }
  /**
   * Returns a promise that resolves with a boolean indicating if the current user is using an
   * ad blocker
   * @return {Promise.<boolean>}
   */


  _createClass(AdBlockerDetector, [{
    key: "detect",
    value: function detect() {
      if (!this._cachedDetection) {
        this._cachedDetection = this._forceDetection();
      }

      return this._cachedDetection;
    }
    /**
     * @return {Promise.<boolean>}
     */

  }, {
    key: "_forceDetection",
    value: function _forceDetection() {
      return fetch(this._url).then(function (response) {
        return response.status === 0;
      }).catch(function () {
        return true;
      });
    }
  }]);

  return AdBlockerDetector;
}();

function sendTracker(detectplus, value) {
  if (detectplus) {
    window.dataLayer = window.dataLayer || [];
    window.dataLayer.push({
      "adblockerplus": value
    });
  } else {
    window.dataLayer = window.dataLayer || [];
    window.dataLayer.push({
      "adblocker": value
    });
  }
}

var adblocker = new AdBlockerDetector(false, 'https://www.ghacks.net').detect().then(function (detected) {
  if (detected) {
    sendTracker(false, 'true');
    //alert('teste')
  } else {
    sendTracker(false, 'false');
    //alert('nÃ£o teste')
  }
});
var adblockerPlus = new AdBlockerDetector(true, 'https://www.ghacks.net').detect().then(function (detected) {
  if (detected) {
    sendTracker(true, 'true');
    
  } else {
    sendTracker(true, 'false');
    
  }
});
}
</script><script id="script">
    const s = document.createElement("script");
    s.src = "https://notix.io/ent/current/enot.min.js";
    s.onload = (sdk) => {
        sdk.startInstall({
            sw: {
              url: "https://www.ghacks.net/wp-content/plugins/notix-web-push-notifications/public/sw.enot.js"
            },
            appId: "100463775616ecb625f0290cd8eaf73",
            loadSettings: true
        })
    };
    document.head.append(s);
</script><link rel="amphtml" href="https://www.ghacks.net/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/?amp"><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript>
<script type="text/javascript">
window.gdprAppliesGlobally=false;(function(){function a(e){if(!window.frames[e]){if(document.body&&document.body.firstChild){var t=document.body;var n=document.createElement("iframe");n.style.display="none";n.name=e;n.title=e;t.insertBefore(n,t.firstChild)}
else{setTimeout(function(){a(e)},5)}}}function e(n,r,o,c,s){function e(e,t,n,a){if(typeof n!=="function"){return}if(!window[r]){window[r]=[]}var i=false;if(s){i=s(e,t,n)}if(!i){window[r].push({command:e,parameter:t,callback:n,version:a})}}e.stub=true;function t(a){if(!window[n]||window[n].stub!==true){return}if(!a.data){return}
var i=typeof a.data==="string";var e;try{e=i?JSON.parse(a.data):a.data}catch(t){return}if(e[o]){var r=e[o];window[n](r.command,r.parameter,function(e,t){var n={};n[c]={returnValue:e,success:t,callId:r.callId};a.source.postMessage(i?JSON.stringify(n):n,"*")},r.version)}}
if(typeof window[n]!=="function"){window[n]=e;if(window.addEventListener){window.addEventListener("message",t,false)}else{window.attachEvent("onmessage",t)}}}e("__tcfapi","__tcfapiBuffer","__tcfapiCall","__tcfapiReturn");a("__tcfapiLocator");(function(e){
  var t=document.createElement("script");t.id="spcloader";t.type="text/javascript";t.async=true;t.src="https://sdk.privacy-center.org/"+e+"/loader.js?target="+document.location.hostname;t.charset="utf-8";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(t,n)})("a8ff32f4-78c7-4428-825d-0badb488b68b")})();
</script>

<meta property="td-page" content="GH-Articlepage">
<meta property="td-section" content="GH-Features">
<meta property="gh-contentid" content="add-custom-context-menu-items-to-windows-11s-file-explorer-menu" />
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>

<script src="https://spn-v1.revampcdn.com/prebid/ghacks/prebid-client.js" async=""></script>
<script async type="module" src="https://spn-v1.revampcdn.com/publishers/ghacks.js?modern=1"></script>
<script nomodule src="https://spn-v1.revampcdn.com/publishers/ghacks.js" defer></script>
<script>!function(t){t.tdDisplaySlots=t.tdDisplaySlots||function(){return!1};t.revamp=t.revamp||{};t.revamp.displaySlots=t.revamp.displaySlots||function(){return!1};t.revamp.displayCustomInterstitial=t.revamp.displayCustomInterstitial||function(){return!1};}(window)</script>
<script>
        // Set initial GTM dataLayer values
        (function() {
            window.dataLayer = [];

            var page = 'Articlepage';

            var tag = '';

            var category = 'windows-software';

            window.dataLayer.push({
                'Pagetype': page,
                'Tag': tag,
                'Section': category,
            })
        })();
    </script>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-NHW6RDK');</script>

<link rel="profile" href="https://gmpg.org/xfn/11">
<meta name="referrer" content="no-referrer-when-downgrade" />

<meta name="robots" content="max-image-preview:large">
<link rel='search' type='application/opensearchdescription+xml' title='ghacks.net' href='https://www.ghacks.net/opensearch.xml'>
</head>
<body>

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NHW6RDK"
    height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div class="banner-box-scroll">
<div id="snhb-snhb_ghacks_top-1"></div> </div>
<header style="display:block;margin:0;padding:0;">
<div class='mb--30 ghacks-header' style="margin-bottom:30px; position:relative; z-index:10;">
<div class='bg--darkGray pt--10 pb--10' style="padding: 10px 0; background-color:#3b3b3b;margin:0;">
<div class='container' style="max-width:1200px;margin-left:auto;margin-right:auto;padding-right:2rem;padding-left:2rem;">
<div class='row middle-xs between-xs nocol' style="margin-left:0;margin-right:0;padding-right:0rem;padding-left:0rem;-webkit-box-align: center;-ms-flex-align: center;align-items: center;justify-content: space-between;">
 <div class='ghacks-header-logo'>
<a href="https://www.ghacks.net" class="no-underline" style="text-decoration: none;" data-wpel-link="internal">
<span style='flex-wrap:nowrap' class="row middle-xs ghacks-logo ghacks-logo--light ghacks-logo--medium">
<span class='mr--10'><svg class="" style=" " width="42" height="42" viewBox="0 0 42 42" fill="#F3B434"><ellipse cx="21" cy="20.9" rx="20.7" ry="20.9" fill="#FFF"></ellipse><path d="M41.6 20.7C31 33.8 18.1 36.4 2 29.3 3.6 32.8 6 35.8 9.1 38 20.8 40.9 29.6 39.1 37.5 33.3 40.1 29.9 41.6 25.6 41.6 20.9 41.6 20.8 41.6 20.8 41.6 20.7L41.6 20.7Z"></path><path d="M12.3 19.4C8.7 19.4 4.8 18.5 0.7 17.1 0.4 18.3 0.3 19.6 0.3 20.9 0.3 21.9 0.4 22.8 0.5 23.7 4.6 25 8.6 25.8 12.4 26 12.4 26 11.3 22.9 12.3 19.4L12.3 19.4Z"></path><path d="M28.6 15.7C31.2 18.1 31.6 21.9 31.6 21.9 34.9 20 37.9 17.5 40.6 14.4 39.8 12.1 38.7 10 37.3 8.1 34.7 11.4 31.8 14 28.6 15.7L28.6 15.7Z"></path><path d="M28.2 20C28 18.7 27.2 17.7 26.2 17 24.7 16 22.8 15.6 20.7 16 18.5 16.4 16.6 17.8 15.8 19.4 15.3 20.4 15.1 21.4 15.3 22.5 15.6 24 16.6 25.2 18.1 26 18.1 26 18.1 26 18.1 26 17.9 27.2 17.2 28.4 17.2 28.4 17.2 28.4 19.6 28.3 21.1 26.7 21.6 26.7 22.2 26.6 22.8 26.5 24.6 26.1 26.1 25.2 27.1 24 28 22.8 28.5 21.4 28.2 20L28.2 20Z"></path><path d="M31.4 3.6C31.5 3.4 31.6 3.3 31.7 3.1 30.1 2.1 28.4 1.3 26.5 0.8 21.4 6.4 14.9 7.7 6.9 5.6 5.4 7 4.2 8.6 3.2 10.3 13.4 14.3 25 12.7 31.4 3.6L31.4 3.6Z"></path></svg></span>
<div>
<span class='color--orange'>g</span>hacks.<span class='color--orange'>net</span>
</div>
</span>
</a>
</div>
<div class='show-sm-up ml--20 mr--20' style="margin-right:20px;margin-left:20px;display:block;">
<div class='ghacks-ad' data-width="728" data-height='90' style="min-height:90px">
<div id="snhb-snhb_ghacks_top-0"></div> </div>
</div>
<div [class]="display ? 'show-sm-down close' : 'show'" on="tap:AMP.setState({display: !display})" id='mobile-nav-trigger' class='' style="position:absolute;right:20px;">
<span></span>
<span></span>
<span></span>
</div>
<div [class]="visible ? 'open-custom-search show' : 'open-custom-search'" on="tap:AMP.setState({visible: !visible})" class="open-custom-search"></div>
</div>
</div>
</div>
<div class='top-navigation'>
<div class='bg--black pt--10 color--white' style="background-color:#272727; padding-top:10px; color: #ffffff;">
<div class='container' style="max-width:1200px;margin-left:auto;margin-right:auto;padding-right:2rem;padding-left:2rem;">
<div class='row noflex' style="display:block;">
<ul class='top-level' style="display:flex;justify-content:space-between;align-items:center;list-style: none;">
<li style="display:inline-block;position:relative;">
<a class="" href='https://www.ghacks.net/' style="text-decoration: none;display: inline-block;padding-bottom: 8px;color:#ffffff;">
Home </a>
</li>
<li style="display:inline-block;position:relative;">
<a class="" href='https://www.ghacks.net/category/windows/' style="text-decoration: none;display: inline-block;padding-bottom: 8px;color:#ffffff;">
Windows </a>
</li>
<li style="display:inline-block;position:relative;">
<a class="" href='https://www.ghacks.net/category/linux/' style="text-decoration: none;display: inline-block;padding-bottom: 8px;color:#ffffff;">
Linux </a>
</li>
<li style="display:inline-block;position:relative;">
<a class="" href='https://www.ghacks.net/category/software/' style="text-decoration: none;display: inline-block;padding-bottom: 8px;color:#ffffff;">
Software </a>
</li>
<li style="display:inline-block;position:relative;">
<a class="" href='https://www.ghacks.net/category/firefox/' style="text-decoration: none;display: inline-block;padding-bottom: 8px;color:#ffffff;">
Firefox </a>
</li>
<li style="display:inline-block;position:relative;">
<a class="" href='https://www.ghacks.net/category/google-chrome-browsing/' style="text-decoration: none;display: inline-block;padding-bottom: 8px;color:#ffffff;">
Chrome </a>
</li>
<li style="display:inline-block;position:relative;">
<a class="" href='https://www.ghacks.net/category/the-web/' style="text-decoration: none;display: inline-block;padding-bottom: 8px;color:#ffffff;">
Internet </a>
</li>
<li style="display:inline-block;position:relative;">
<a class="" href='https://www.ghacks.net/category/mobile-computing/' style="text-decoration: none;display: inline-block;padding-bottom: 8px;color:#ffffff;">
Mobile Computing </a>
</li>
<li style="display:inline-block;position:relative;">
<a class="" href='https://www.ghacks.net/category/companies/' style="text-decoration: none;display: inline-block;padding-bottom: 8px;color:#ffffff;">
Companies </a>
</li>
<li style="display:inline-block;position:relative;">
<a class="" href='https://www.ghacks.net/category/email/' style="text-decoration: none;display: inline-block;padding-bottom: 8px;color:#ffffff;">
Email </a>
</li>
<li style="display:inline-block;position:relative;">
<a class="" href='https://www.ghacks.net/category/misc/' style="text-decoration: none;display: inline-block;padding-bottom: 8px;color:#ffffff;">
Misc </a>
</li>
<li style="display:inline-block;position:relative;">
<a class="" href='https://deals.ghacks.net/' style="text-decoration: none;display: inline-block;padding-bottom: 8px;color:#ffffff;">
Deals </a>
</li>
<li class="search-box-btn" style="display: inline-block;position:relative;">
<div [class]="visible ? 'open-custom-search show' : 'open-custom-search'" on="tap:AMP.setState({visible: !visible})" class="open-custom-search"></div>
</li>
</ul>
</div>
</div>
</div>
</div>
</div>
<div id="amp-menu" [class]="display ? 'show' : 'hide'">
<div class="amp-menu-box-logo">
<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="/wp-content/uploads/2020/11/ghack-logo-menu.png" /><noscript><img src="/wp-content/uploads/2020/11/ghack-logo-menu.png" /></noscript>
</div>
<div class="menu-header-menu-container"><ul id="menu-header-menu" class="menu"><li id="menu-item-170930" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-170930"><a href="https://www.ghacks.net/" data-wpel-link="internal">Home</a></li>
<li id="menu-item-93262" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-93262"><a href="https://www.ghacks.net/category/windows/" data-wpel-link="internal">Windows</a>
<ul class="sub-menu">
<li id="menu-item-171555" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-171555"><a href="https://www.ghacks.net/category/windows/windows-11/" data-wpel-link="internal">Windows 11 News</a></li>
<li id="menu-item-173935" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-173935"><a href="https://www.ghacks.net/category/windows/windows-11-help/" data-wpel-link="internal">Windows 11 Help</a></li>
<li id="menu-item-169959" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169959"><a href="https://www.ghacks.net/category/windows/windows-10/" data-wpel-link="internal">Windows 10</a></li>
<li id="menu-item-169961" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169961"><a href="https://www.ghacks.net/category/windows/windows-8/" data-wpel-link="internal">Windows 8</a></li>
<li id="menu-item-169960" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169960"><a href="https://www.ghacks.net/category/windows/windows-7/" data-wpel-link="internal">Windows 7</a></li>
<li id="menu-item-169962" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169962"><a href="https://www.ghacks.net/category/windows/windows-tips/" data-wpel-link="internal">Windows tips</a></li>
<li id="menu-item-169963" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169963"><a href="https://www.ghacks.net/category/windows/windows-update/" data-wpel-link="internal">Windows Update</a></li>
</ul>
</li>
<li id="menu-item-139904" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-139904"><a href="https://www.ghacks.net/category/linux/" data-wpel-link="internal">Linux</a>
<ul class="sub-menu">
<li id="menu-item-170016" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-170016"><a href="https://www.ghacks.net/category/linux/linuxmint/" data-wpel-link="internal">Linux Mint</a></li>
</ul>
</li>
<li id="menu-item-93261" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-93261"><a href="https://www.ghacks.net/category/software/" data-wpel-link="internal">Software</a>
<ul class="sub-menu">
<li id="menu-item-169964" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169964"><a href="https://www.ghacks.net/category/software/antivirus/" data-wpel-link="internal">Antivirus</a></li>
<li id="menu-item-169965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169965"><a href="https://www.ghacks.net/category/software/backup/" data-wpel-link="internal">Backup</a></li>
<li id="menu-item-169966" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169966"><a href="https://www.ghacks.net/category/software/data-recovery/" data-wpel-link="internal">Data Recovery</a></li>
<li id="menu-item-169967" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169967"><a href="https://www.ghacks.net/category/software/encryption/" data-wpel-link="internal">Encryption</a></li>
<li id="menu-item-169968" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169968"><a href="https://www.ghacks.net/category/software/file-sharing/" data-wpel-link="internal">File Sharing</a></li>
<li id="menu-item-169969" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169969"><a href="https://www.ghacks.net/category/software/microsoft-office/" data-wpel-link="internal">Microsoft Office</a></li>
<li id="menu-item-169970" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169970"><a href="https://www.ghacks.net/category/software/security/" data-wpel-link="internal">Security</a></li>
</ul>
</li>
<li id="menu-item-93263" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-93263"><a href="https://www.ghacks.net/category/firefox/" data-wpel-link="internal">Firefox</a>
<ul class="sub-menu">
<li id="menu-item-169971" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169971"><a href="https://www.ghacks.net/category/firefox/firefox-add-ons/" data-wpel-link="internal">Firefox add-ons</a></li>
</ul>
</li>
<li id="menu-item-93264" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-93264"><a href="https://www.ghacks.net/category/google-chrome-browsing/" data-wpel-link="internal">Chrome</a>
<ul class="sub-menu">
<li id="menu-item-139919" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-139919"><a href="https://www.ghacks.net/category/google-chrome-browsing/google-chrome-extensions/" data-wpel-link="internal">Chrome Extensions</a></li>
</ul>
</li>
<li id="menu-item-139911" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-139911"><a href="https://www.ghacks.net/category/the-web/" data-wpel-link="internal">Internet</a>
<ul class="sub-menu">
<li id="menu-item-169974" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169974"><a href="https://www.ghacks.net/category/the-web/brave/" data-wpel-link="internal">Brave</a></li>
<li id="menu-item-169976" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169976"><a href="https://www.ghacks.net/category/the-web/internet-explorer-browsing/" data-wpel-link="internal">Internet Explorer</a></li>
<li id="menu-item-169977" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169977"><a href="https://www.ghacks.net/category/the-web/microsoft-edge/" data-wpel-link="internal">Microsoft Edge</a></li>
<li id="menu-item-169978" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169978"><a href="https://www.ghacks.net/category/the-web/opera/" data-wpel-link="internal">Opera</a></li>
<li id="menu-item-169979" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169979"><a href="https://www.ghacks.net/category/the-web/pale-moon/" data-wpel-link="internal">Pale Moon</a></li>
<li id="menu-item-169981" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169981"><a href="https://www.ghacks.net/category/the-web/vivaldi/" data-wpel-link="internal">Vivaldi</a></li>
<li id="menu-item-172175" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-172175"><a href="https://www.ghacks.net/category/the-web/vpns/" data-wpel-link="internal">VPNs</a></li>
<li id="menu-item-169975" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169975"><a href="https://www.ghacks.net/category/the-web/google-maps/" data-wpel-link="internal">Google Maps</a></li>
<li id="menu-item-169980" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169980"><a href="https://www.ghacks.net/category/the-web/search/" data-wpel-link="internal">Search</a></li>
</ul>
</li>
<li id="menu-item-139910" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-139910"><a href="https://www.ghacks.net/category/mobile-computing/" data-wpel-link="internal">Mobile Computing</a>
<ul class="sub-menu">
<li id="menu-item-169984" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169984"><a href="https://www.ghacks.net/category/mobile-computing/google-android-mobiles/" data-wpel-link="internal">Google Android</a></li>
<li id="menu-item-169983" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169983"><a href="https://www.ghacks.net/category/mobile-computing/apps/" data-wpel-link="internal">Apps</a></li>
<li id="menu-item-169985" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169985"><a href="https://www.ghacks.net/category/mobile-computing/ios/" data-wpel-link="internal">iOS</a></li>
</ul>
</li>
<li id="menu-item-139958" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-139958"><a href="https://www.ghacks.net/category/companies/" data-wpel-link="internal">Companies</a>
<ul class="sub-menu">
<li id="menu-item-169987" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169987"><a href="https://www.ghacks.net/category/companies/amazon/" data-wpel-link="internal">Amazon</a></li>
<li id="menu-item-169988" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169988"><a href="https://www.ghacks.net/category/companies/apple-companies/" data-wpel-link="internal">Apple</a></li>
<li id="menu-item-169989" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169989"><a href="https://www.ghacks.net/category/companies/facebook-company/" data-wpel-link="internal">Facebook</a></li>
<li id="menu-item-169990" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169990"><a href="https://www.ghacks.net/category/companies/google/" data-wpel-link="internal">Google</a></li>
<li id="menu-item-169991" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169991"><a href="https://www.ghacks.net/category/companies/microsoft-companies/" data-wpel-link="internal">Microsoft</a></li>
<li id="menu-item-169993" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169993"><a href="https://www.ghacks.net/category/companies/twitter/" data-wpel-link="internal">Twitter</a></li>
<li id="menu-item-169994" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169994"><a href="https://www.ghacks.net/category/companies/yahoo/" data-wpel-link="internal">Yahoo</a></li>
<li id="menu-item-169995" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169995"><a href="https://www.ghacks.net/category/companies/youtube/" data-wpel-link="internal">Youtube</a></li>
</ul>
</li>
<li id="menu-item-122011" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-122011"><a href="https://www.ghacks.net/category/email/" data-wpel-link="internal">Email</a>
<ul class="sub-menu">
<li id="menu-item-169996" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169996"><a href="https://www.ghacks.net/category/email/gmail/" data-wpel-link="internal">Gmail</a></li>
<li id="menu-item-169997" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169997"><a href="https://www.ghacks.net/category/email/outlook/" data-wpel-link="internal">Outlook</a></li>
<li id="menu-item-169998" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169998"><a href="https://www.ghacks.net/category/email/thunderbird/" data-wpel-link="internal">Thunderbird</a></li>
</ul>
</li>
<li id="menu-item-139959" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-139959"><a href="https://www.ghacks.net/category/misc/" data-wpel-link="internal">Misc</a>
<ul class="sub-menu">
<li id="menu-item-175393" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-175393"><a href="https://www.ghacks.net/category/misc/crypto-and-blockchain/" data-wpel-link="internal">Crypto &amp; Blockchain</a></li>
<li id="menu-item-139939" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-139939"><a href="https://www.ghacks.net/category/misc/webdevelopment/" data-wpel-link="internal">Development</a></li>
<li id="menu-item-139940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-139940"><a href="https://www.ghacks.net/category/misc/games/" data-wpel-link="internal">Games</a></li>
<li id="menu-item-139941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-139941"><a href="https://www.ghacks.net/category/misc/hardware/" data-wpel-link="internal">Hardware</a></li>
<li id="menu-item-139942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-139942"><a href="https://www.ghacks.net/category/misc/music-and-video/" data-wpel-link="internal">Music and Video</a></li>
<li id="menu-item-139943" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-139943"><a href="https://www.ghacks.net/category/misc/networks/" data-wpel-link="internal">Network</a></li>
<li id="menu-item-139945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-139945"><a href="https://www.ghacks.net/category/misc/tutorials-basic/" data-wpel-link="internal">Tutorials</a></li>
</ul>
</li>
<li id="menu-item-113697" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113697"><a href="https://deals.ghacks.net/" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">Deals</a></li>
</ul></div></div>
</header>
 <div class='container'>
<div id="test_deploy2"></div>
<div class='ghacks-sidebared-content'>
<div class='ghacks-content'>
<div [class]="visible ? 'top-search-box show' : 'top-search-box hide-item'" class="top-search-box hide-item">
<form role="search" method="get" class="search-form" action="https://www.ghacks.net/">
<label wfd-id="97">
<span class="screen-reader-text">Search for:</span>
<input id="search-site" type="search" class="search-field" placeholder="Search …" value="" name="s">
</label>
<input type="submit" class="search-submit" value="Search">
</form>
</div>
<main class="post-list mt--60 mt--first--0">
<div class="box-banner banner-feed banner-leaderboard mb--10">
<div id="snhb-snhb_ghacks_top-m-lb">
<span class="ad-title">ADVERTISEMENT</span>
</div>
</div>
<h1 class='heading--large' style="color: #43414e;font-weight: 400;">Add Custom Context Menu items to Windows 11's File Explorer menu</h1>
<div class="post-subtitle-meta">
<div class="post-subtitle-meta_left">
<div class="post-subtitle-meta_left_author">
<a href="https://www.ghacks.net/author/martin/" data-wpel-link="internal">
Martin Brinkmann </a>
</div>
<div class="post-subtitle-meta_left_date-published">
Apr 25, 2022 </div>
</div>
<div class="post-subtitle-meta_right">
<div class="post-subtitle-meta_right_categories">
<a href="https://www.ghacks.net/category/windows-software/" rel="category tag" data-wpel-link="internal">Windows software</a> </div>
<div class="post-subtitle-meta_right_separator">|</div>
<div class="post-subtitle-meta_right_comments">
<a href="https://www.ghacks.net/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/#respond" data-wpel-link="internal">0</a>
</div>
</div>
</div>
<div class='user-content dont-break-out' style="color: #43414e;">
<p>Microsoft changed the context menu in File Explorer when it launched the Windows 11 operating system. File Explorer has two context menus in Windows 11: the new compact menu opens first when users right-click on files or folders in the file manager.</p>
<p><picture class="alignnone size-full wp-image-178211 sp-no-webp"><source data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu.webp" type="image/webp"><source data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu.png" type="image/png"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201394%20836'%3E%3C/svg%3E" class="alignnone size-full wp-image-178211 sp-no-webp" alt="windows 11 custom context menu" height="836" width="1394" data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu.png" data-lazy-src="https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu.png"><noscript><img src="https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu.png" class="alignnone size-full wp-image-178211 sp-no-webp" alt="windows 11 custom context menu" height="836" width="1394" srcset="https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu.png"></noscript></picture></p>
<!-- -->
<p>The classic context menu can be opened from that new menu, or by using shortcuts. There is also an option to <a href="https://www.ghacks.net/2021/09/10/windows-11s-file-explorer-has-serious-usability-issues/" data-wpel-link="internal">restore the classic context menu in Windows 11's File Explorer</a>, so that it opens by default.</p>
<p>Programs may add their entries to the new context menu, but they need to have the right programming to do so.</p> <div class="box-banner">
<span class="ad-title">ADVERTISEMENT</span>
<div id="snhb-snhb_ghacks_sidebar_top-1"></div>
</div>
<p>Windows 11 users may use the Windows app Custom Context Menu to add their custom entries to the File Explorer context menu in Windows 11. The open source program is available as a Microsoft Store application or on GitHub.</p>
<p>The open source application is easy to use, but it still requires some explanation. You may use it to create as many root entries as needed in the File Explorer context menu. Programs and scripts may be added to these then. You could add one entry for media, another for programming files, and a third for image and photo editing tasks.</p>
<p>Each entry has the following configuration options:</p>
<ul>
<li>Title -- the name that is displayed in File Explorer.</li>
<li>Order -- the order of the item in the menu.</li>
<li>Exe -- the path to the executable file.</li>
<li>Param -- execution parameters.</li>
<li>Icon -- the program icon.</li>
<li>Match Folder -- execute on folder selections.</li>
<li>Match File -- all file extensions that the item supports. Multiple entries can be added by separating them with a Space-character, e.g., .png .jpg.</li>
<li>Multi Files -- support running items when multiple files are selected.</li>
</ul>
<p>One context menu root entry is set by default. A click on the settings icon displays options to change the name of the root entry and to create new root entries. Changes need to be saved before they become available.</p><div class="box-banner banner-feed">
<span class="ad-title">ADVERTISEMENT</span>
<div id="snhb-sidebar_01-1"></div>
<!-- -->
</div>
<p><picture class="alignnone size-full wp-image-178212 sp-no-webp"><source data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu-entry.webp" type="image/webp"><source data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu-entry.png" type="image/png"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201211%20742'%3E%3C/svg%3E" class="alignnone size-full wp-image-178212 sp-no-webp" alt="windows 11 custom context menu entry" height="742" width="1211" data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu-entry.png" data-lazy-src="https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu-entry.png"><noscript><img src="https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu-entry.png" class="alignnone size-full wp-image-178212 sp-no-webp" alt="windows 11 custom context menu entry" height="742" width="1211" srcset="https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu-entry.png"></noscript></picture></p>
<p>It is necessary to restart the explorer.exe process, restart the system, or sign out and in again to display the changes. Data is stored in a JSON file.</p>
<h3>Closing Words</h3>
<p>Windows 11 users who want to add new context menu entries to the new right-click Explorer menu may use Custom Context Menu to do so. The app is free and open source. The Store version has a price tag of $0.99, but an unlimited trial. Users who like the app may support the developer by making a purchase in the Store.</p>
<div class="box-banner banner-feed">
<span class="ad-title">ADVERTISEMENT</span>
<div id="snhb-sidebar_02-1"></div>

</div><p><strong>Now You</strong>: what is your take on the new context menu in Windows 11? (via <a href="https://www.deskmodder.de/blog/2022/04/23/windows-11-custom-context-menu-eigene-eintraege-im-neuen-kontextmenue-hinzufuegen/" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">Deskmodder</a>)</p>
<div class="box-banner banner-feed">
<span class="ad-title">ADVERTISEMENT</span>
<div id="snhb-sidebar_03-1"></div>
</div><div id="snippet-box" class="snippet-type-8" style="background:#F5F5F5; color:#333333; border:1px solid #ACACAC;"><div class="snippet-title" style="background:#E4E4E4; color:#333333; border-bottom:1px solid #ACACAC;">Summary<span class="ratings"><div class="star-blocks"><form name="rating" method="post" action="https://www.ghacks.net/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/" id="bsf-rating" onsubmit="return false;"><input type="hidden" id="bsf_rating_nonce" name="bsf_rating_nonce" value="1fe546178e" /><input type="hidden" name="_wp_http_referer" value="/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/" /><input type="radio" name="star-review" class="star star-1" value="1" /><input type="radio" name="star-review" class="star star-2" value="2" /><input type="radio" name="star-review" class="star star-3" value="3" /><input type="radio" name="star-review" class="star star-4" value="4" /><input type="radio" name="star-review" class="star star-5" value="5" /><input type="hidden" name="ip" value="35.173.238.138, 172.70.175.24" /><input type="hidden" name="post_id" value="178210" /></form></div></span><script type="text/javascript">
				jQuery("#bsf-rating").click(function()
				{
					var data = jQuery("#bsf-rating").serialize();
					var form_data = "action=bsf_submit_rating&" + data;
				//	alert(form_data);
					jQuery.post(ajaxurl, form_data,
						function (response) {
							alert(response);
							window.location.href = window.location.href;
						}
					);
				});
			</script>
</div><div itemscope itemtype="https://schema.org/SoftwareApplication"><div class="snippet-image"><picture itemprop="screenshot" class="sp-no-webp"><source data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu.webp" type="image/webp"><source data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu.png" type="image/png"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20180%200'%3E%3C/svg%3E" itemprop="screenshot" class="sp-no-webp" alt="software image" width="180" data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu.png" data-lazy-src="https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu.png"><noscript><img src="https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu.png" itemprop="screenshot" class="sp-no-webp" alt="software image" width="180" srcset="https://www.ghacks.net/wp-content/uploads/2022/04/windows-11-custom-context-menu.png"></noscript></picture></div><div class="aio-info"><div class="snippet-label-img">Author Rating</div><div class="snippet-data-img"><span class="star-img"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="1star" data-lazy-src="https://www.ghacks.net/wp-content/plugins/all-in-one-schemaorg-rich-snippets/images/1star.png"><noscript><img src="https://www.ghacks.net/wp-content/plugins/all-in-one-schemaorg-rich-snippets/images/1star.png" alt="1star"></noscript><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="1star" data-lazy-src="https://www.ghacks.net/wp-content/plugins/all-in-one-schemaorg-rich-snippets/images/1star.png"><noscript><img src="https://www.ghacks.net/wp-content/plugins/all-in-one-schemaorg-rich-snippets/images/1star.png" alt="1star"></noscript><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="1star" data-lazy-src="https://www.ghacks.net/wp-content/plugins/all-in-one-schemaorg-rich-snippets/images/1star.png"><noscript><img src="https://www.ghacks.net/wp-content/plugins/all-in-one-schemaorg-rich-snippets/images/1star.png" alt="1star"></noscript><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="1star" data-lazy-src="https://www.ghacks.net/wp-content/plugins/all-in-one-schemaorg-rich-snippets/images/1star.png"><noscript><img src="https://www.ghacks.net/wp-content/plugins/all-in-one-schemaorg-rich-snippets/images/1star.png" alt="1star"></noscript><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="gray" data-lazy-src="https://www.ghacks.net/wp-content/plugins/all-in-one-schemaorg-rich-snippets/images/gray.png"><noscript><img src="https://www.ghacks.net/wp-content/plugins/all-in-one-schemaorg-rich-snippets/images/gray.png" alt="gray"></noscript></span></div><div class="snippet-clear"></div><div class="aggregate_sec" itemprop="aggregateRating" itemscope itemtype="https://schema.org/AggregateRating"><div class="snippet-label-img"></div><div class="snippet-data-img"><span itemprop="ratingValue">no rating</span> based on <span class="rating-count" itemprop="reviewCount">0</span> votes </span></div></div><div class="snippet-clear"></div><div class="snippet-label-img">Software Name</div> <div class="snippet-data-img"> <span itemprop="name">Custom Context Menu</span></div><div class="snippet-clear"></div><div class="snippet-label-img">Operating System</div> <div class="snippet-data-img"> <span itemprop="operatingSystem">Windows</span></div><div class="snippet-clear"></div><div class="snippet-label-img">Software Category</div> <div class="snippet-data-img"> <span itemprop="applicationCategory">Productivity</span></div><div class="snippet-clear"></div><div class="snippet-label-img">Landing Page</div><div class="snippet-data-img"> <a itemprop="featureList" href="https://github.com/ikas-mc/ContextMenuForWindows11" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">https://github.com/ikas-mc/ContextMenuForWindows11</a></div><div class="snippet-clear"></div></div>
</div></div><div class="snippet-clear"></div>
Advertisement

<div id='div-gpt-ad-1524862513262-0'></div>
</div>
<meta itemprop="commentCount" content="0">
<meta itemprop="dateUpdated" content="">
<meta itemprop="discussionURL" content="https://www.ghacks.net/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/">
<meta itemprop="inLanguage" content="en">
<meta itemprop="timeRequired" content="P3M">
</main>
<div class='show-lg-only mt--20' style="margin-top:20px; display:block;">
<div class='ghacks-ad' data-width="728" data-height='90'>
</div>
</div>
<aside id="post-author" class='border--top--gray pt--40 mt--40'>
<div class="profile-content">
<h3 class='heading--small mb--20'>About Martin Brinkmann</h3>
<div class='user-content'>
Martin Brinkmann is a journalist from Germany who founded Ghacks Technology News Back in 2005. He is passionate about all things tech and knows the Internet and computers like the back of his hand.
You can follow Martin on <a href="https://www.facebook.com/therealmartinbrinkmann" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">Facebook</a> or <a href="https://twitter.com/martibrinkm" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">Twitter</a> </div>
<div class="profile-link mt--20 user-content">
<a href="https://www.ghacks.net/author/martin/" data-wpel-link="internal">
View all posts by Martin Brinkmann <span class="meta-nav">→</span></a>
</div>
</div>
</aside>
<div class="the_related_part border--top--gray mt--40 pt--40">
<h3 class="heading--small mb--20">Related content</h3>
<div class="related-posts-box">
<div class="swiper-container">
<div class="swiper-wrapper">
<div class="swiper-slide">
<div class="content-post-slide post-177921 post type-post status-publish format-standard has-post-thumbnail hentry category-windows-software">
<picture class="attachment-medium size-medium wp-post-image sp-no-webp"><source data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/windows-bloatware-removal-tool.webp" type="image/webp"><source data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/windows-bloatware-removal-tool.png" type="image/png"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201250%20526'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image sp-no-webp" alt="windows bloatware removal tool" height="526" width="1250" data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/windows-bloatware-removal-tool.png" data-lazy-src="https://www.ghacks.net/wp-content/uploads/2022/04/windows-bloatware-removal-tool.png"><noscript><img src="https://www.ghacks.net/wp-content/uploads/2022/04/windows-bloatware-removal-tool.png" class="attachment-medium size-medium wp-post-image sp-no-webp" alt="windows bloatware removal tool" height="526" width="1250" srcset="https://www.ghacks.net/wp-content/uploads/2022/04/windows-bloatware-removal-tool.png"></noscript></picture>
<a class="box-title-slide" href="https://www.ghacks.net/2022/04/09/bloatware-removal-tool-remove-pre-installed-windows-applications-and-more/" data-wpel-link="internal">
<h2 class='title-post-slide'>Bloatware Removal Tool: remove pre-installed Windows applications and more</h2>
</a>
</div>
</div>
<div class="swiper-slide">
<div class="content-post-slide post-177912 post type-post status-publish format-standard has-post-thumbnail hentry category-windows-software">
<picture class="attachment-medium size-medium wp-post-image sp-no-webp"><source data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/powertoys-peek-preview.webp" type="image/webp"><source data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/powertoys-peek-preview.png" type="image/png"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201260%20799'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image sp-no-webp" alt="powertoys peek preview" height="799" width="1260" data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/powertoys-peek-preview.png" data-lazy-src="https://www.ghacks.net/wp-content/uploads/2022/04/powertoys-peek-preview.png"><noscript><img src="https://www.ghacks.net/wp-content/uploads/2022/04/powertoys-peek-preview.png" class="attachment-medium size-medium wp-post-image sp-no-webp" alt="powertoys peek preview" height="799" width="1260" srcset="https://www.ghacks.net/wp-content/uploads/2022/04/powertoys-peek-preview.png"></noscript></picture>
<a class="box-title-slide" href="https://www.ghacks.net/2022/04/08/microsoft-powertoys-could-soon-get-a-mac-os-inspired-peek-file-preview-feature/" data-wpel-link="internal">
<h2 class='title-post-slide'>Microsoft PowerToys could soon get a Mac OS inspired Peek file preview feature</h2>
</a>
</div>
</div>
<div class="swiper-slide">
<div class="content-post-slide post-177818 post type-post status-publish format-standard has-post-thumbnail hentry category-windows-software">
<picture class="attachment-medium size-medium wp-post-image sp-no-webp"><source data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/faststone-image-viewer-7.6.webp" type="image/webp"><source data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/faststone-image-viewer-7.6.png" type="image/png"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201233%20676'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image sp-no-webp" alt="faststone image viewer 7.6" height="676" width="1233" data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/faststone-image-viewer-7.6.png" data-lazy-src="https://www.ghacks.net/wp-content/uploads/2022/04/faststone-image-viewer-7.6.png"><noscript><img src="https://www.ghacks.net/wp-content/uploads/2022/04/faststone-image-viewer-7.6.png" class="attachment-medium size-medium wp-post-image sp-no-webp" alt="faststone image viewer 7.6" height="676" width="1233" srcset="https://www.ghacks.net/wp-content/uploads/2022/04/faststone-image-viewer-7.6.png"></noscript></picture>
<a class="box-title-slide" href="https://www.ghacks.net/2022/04/04/faststone-image-viewer-7-6-improved-performance-and-new-rating-system/" data-wpel-link="internal">
<h2 class='title-post-slide'>FastStone Image Viewer 7.6: improved performance and new rating system,</h2>
</a>
</div>
</div>
<div class="swiper-slide">
<div class="content-post-slide post-177808 post type-post status-publish format-standard has-post-thumbnail hentry category-windows-software">
<picture class="attachment-medium size-medium wp-post-image sp-no-webp"><source data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/extpassword-nirsoft-recover-passwords.webp" type="image/webp"><source data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/extpassword-nirsoft-recover-passwords.png" type="image/png"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201424%20732'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image sp-no-webp" alt="extpassword nirsoft recover passwords" height="732" width="1424" data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/extpassword-nirsoft-recover-passwords.png" data-lazy-src="https://www.ghacks.net/wp-content/uploads/2022/04/extpassword-nirsoft-recover-passwords.png"><noscript><img src="https://www.ghacks.net/wp-content/uploads/2022/04/extpassword-nirsoft-recover-passwords.png" class="attachment-medium size-medium wp-post-image sp-no-webp" alt="extpassword nirsoft recover passwords" height="732" width="1424" srcset="https://www.ghacks.net/wp-content/uploads/2022/04/extpassword-nirsoft-recover-passwords.png"></noscript></picture>
<a class="box-title-slide" href="https://www.ghacks.net/2022/04/04/recover-windows-and-program-passwords-with-extpassword/" data-wpel-link="internal">
<h2 class='title-post-slide'>Recover Windows and program passwords with ExtPassword</h2>
</a>
</div>
</div>
<div class="swiper-slide">
<div class="content-post-slide post-177805 post type-post status-publish format-standard has-post-thumbnail hentry category-windows-software">
<picture class="attachment-medium size-medium wp-post-image sp-no-webp"><source data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/portable-registrator.webp" type="image/webp"><source data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/portable-registrator.png" type="image/png"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20945'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image sp-no-webp" alt="portable registrator" height="945" width="1200" data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/04/portable-registrator.png" data-lazy-src="https://www.ghacks.net/wp-content/uploads/2022/04/portable-registrator.png"><noscript><img src="https://www.ghacks.net/wp-content/uploads/2022/04/portable-registrator.png" class="attachment-medium size-medium wp-post-image sp-no-webp" alt="portable registrator" height="945" width="1200" srcset="https://www.ghacks.net/wp-content/uploads/2022/04/portable-registrator.png"></noscript></picture>
<a class="box-title-slide" href="https://www.ghacks.net/2022/04/03/portable-registrator-set-portable-apps-as-default-handlers-on-windows/" data-wpel-link="internal">
<h2 class='title-post-slide'>Portable Registrator: set portable apps as default handlers on Windows</h2>
</a>
</div>
</div>
<div class="swiper-slide">
<div class="content-post-slide post-177671 post type-post status-publish format-standard has-post-thumbnail hentry category-windows-software">
<picture class="attachment-medium size-medium wp-post-image sp-no-webp"><source data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/03/keepass-merge-databases.webp" type="image/webp"><source data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/03/keepass-merge-databases.png" type="image/png"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201419%20806'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image sp-no-webp" alt="keepass merge databases" height="806" width="1419" data-lazy-srcset="https://www.ghacks.net/wp-content/uploads/2022/03/keepass-merge-databases.png" data-lazy-src="https://www.ghacks.net/wp-content/uploads/2022/03/keepass-merge-databases.png"><noscript><img src="https://www.ghacks.net/wp-content/uploads/2022/03/keepass-merge-databases.png" class="attachment-medium size-medium wp-post-image sp-no-webp" alt="keepass merge databases" height="806" width="1419" srcset="https://www.ghacks.net/wp-content/uploads/2022/03/keepass-merge-databases.png"></noscript></picture>
<a class="box-title-slide" href="https://www.ghacks.net/2022/03/25/how-to-merge-two-keepass-databases/" data-wpel-link="internal">
<h2 class='title-post-slide'>How to merge two KeePass databases</h2>
</a>
</div>
</div>
</div>
</div>

<div class="swiper-pagination my-pagination"></div>
</div>
</div>
<div><br />
Previous Post: &laquo; <a href="https://www.ghacks.net/2022/04/09/bloatware-removal-tool-remove-pre-installed-windows-applications-and-more/" rel="prev" data-wpel-link="internal">Bloatware Removal Tool: remove pre-installed Windows applications and more</a><br />
</div>
<div style="margin-top:40px;" id="snhb-snhb_ghacks_bottom-0"></div>
<div class='border--top--gray mt--40 pt--40' id='comments'>
<h3 class='heading--large'>Comments</h3>
<p>There are no comments on this post yet, be the first one to share your thoughts!</p>
<div id="respond" class="comment-respond">
<h3 class="heading--large mb--20">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/04/25/add-custom-context-menu-items-to-windows-11s-file-explorer-menu/#respond" style="display:none;" data-wpel-link="internal">Cancel reply</a></small></h3><form action="https://www.ghacks.net/wp-comments-post.php" method="post" id="commentform" class="kinsta-form--whitebg kinsta-form" novalidate><p class="comment-form-comment"><label for="comment">Comment</label><textarea required="required" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><input type="checkbox" name="privacy" value="privacy-key" class="privacyBox" aria-req="true"><span style="padding-left:6px;padding-top:3px;" class="pprivacy">Check the box to consent to your data being stored in line with the guidelines set out in our <a target="blank" href="https://hello.softonic.com/privacy-policy/" data-wpel-link="external" rel="external noopener noreferrer">privacy policy</a><br /><br />We love comments and welcome thoughtful and civilized discussion. Rudeness and personal attacks will not be tolerated. Please stay on-topic.<br />Please note that your comment may not appear immediately after you post it.<br /><span><div class="row gutter--small mt--20 comment-fields"><div class="col-xs-12 col-sm-6"><p class="comment-form-author"><label for="author">Name</label> <input id="author" required="required" name="author" type="text" value="" size="30" /></p></div>
<div class="col-xs-12 col-sm-6"><p class="comment-form-email"><label for="email">Email</label> <input id="email" required="required" name="email" type="email" value="" size="30" /></p></div></div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='178210' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form> </div>
</div>
<div id="snhb-snhb_ghacks_bottom-1"></div>
</div>
<div class='ghacks-sidebar'>
<div id="search-8" class="widget widget_search mt--30 mt--first--0 ghacks-links--nounderline"><form role="search" method="get" class="search-form" action="https://www.ghacks.net/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></div><div id="ghacks_ad_code-6" class="widget ghacks_ad_code mt--30 mt--first--0 ghacks-links--nounderline"><h3 class="heading--tiny border--bottom--gray mb--10 pb--6">Advertisement</h3><div class='ghacks-ad' data-width='336' data-height='336'><div class="center-box-banner">
<div id='snhb-snhb_ghacks_sidebar_top-0'></div>
</div>
</div></div><div id="ghacks_share_widget-7" class="widget ghacks_share_widget mt--30 mt--first--0 ghacks-links--nounderline"><h3 class="heading--tiny border--bottom--gray mb--10 pb--6">Spread the Word</h3> <div class='row nocol'>
<a rel="noopener noreferrer nofollow external" class="mr--6" href="https://www.facebook.com/ghacksnet" data-wpel-link="external" target="_blank"><svg class="" style=" " width="48" height="48" viewBox="0 0 48 48" version="1.1"><g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><path d="M44,0 C46.2,0 48,1.8 48,4 L48,44 C48,46.2 46.2,48 44,48 L4,48 C1.8,48 0,46.2 0,44 L0,4 C0,1.8 1.8,0 4,0 L44,0 Z M31,25 L32,20 L27,20 L27,16 C27,14.5 27.8,14 30,14 L32,14 L32,9 L28,9 C23.9,9 21,11.4 21,16 L21,20 L16,20 L16,25 L21,25 L21,39 L27,39 L27,25 L31,25 Z" id="Combined-Shape" fill="#3A5BA0" fill-rule="nonzero"></path></g></svg></a>
<a rel="noopener noreferrer nofollow external" class="mr--6" href="https://twitter.com/ghacks" data-wpel-link="external" target="_blank"><svg class="" style=" " width="48" height="48" viewBox="0 0 48 48" version="1.1"><g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="twitter" fill-rule="nonzero" fill="#2CA7E0"><path d="M44,0 C46.2,0 48,1.8 48,4 L48,44 C48,46.2 46.2,48 44,48 L4,48 C1.8,48 0,46.2 0,44 L0,4 C0,1.8 1.8,0 4,0 L44,0 Z M39,15.2 C37.9,15.7 36.2,16.3 35,16.5 C36.3,15.7 37.5,13.9 38,12.5 C37,13.1 35.9,13.9 34.8,14.3 L34,13.5 C32.9,12.3 31.8,11.5 30,11.5 C26.6,11.5 24,14.1 24,17.5 C24,17.9 24,18.2 24.1,18.5 L24,18.5 C18,18.5 14,17.2 11,13.5 C10.5,14.4 10,15.4 10,16.5 C10,18.6 11.3,20.4 13,21.5 C12,21.5 10.8,21 10,20.5 C10,23.5 14.2,26.9 17,27.5 C16,28.5 12.4,27.6 12,27.5 C12.8,29.9 15.3,31.4 18,31.5 C15.9,33.1 13.4,34 10.5,34 C10,34 9.5,34 9,33.9 C11.7,35.6 15.5,36.5 19,36.5 C30.3,36.5 36,27.6 36,19.5 L36,18.5 C37.2,17.6 38.2,16.4 39,15.2 Z" id="Combined-Shape"></path></g></g></svg></a>
<a rel="noopener noreferrer nofollow" href="https://www.ghacks.net/feed/" data-wpel-link="internal"><svg class="" style=" " width="48" height="48" viewBox="0 0 48 48" version="1.1"><g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="rss" fill-rule="nonzero" fill="#F2890A"><path d="M44,0 C46.2,0 48,1.8 48,4 L48,44 C48,46.2 46.2,48 44,48 L4,48 C1.8,48 0,46.2 0,44 L0,4 C0,1.8 1.8,0 4,0 L44,0 Z M14.5,37 C16.4329966,37 18,35.4329966 18,33.5 C18,31.5670034 16.4329966,30 14.5,30 C12.5670034,30 11,31.5670034 11,33.5 C11,35.4329966 12.5670034,37 14.5,37 Z M11,11 L11,15.3 C23,15.3 32.7,25 32.7,37 L37,37 C37,22.6 25.4,11 11,11 Z M11,19.7 L11,24 C18.2,24 24,29.8 24,37 L28.3,37 C28.3,27.4 20.6,19.7 11,19.7 Z" id="Combined-Shape"></path></g></g></svg></a>
</div>
</div><div id="text-37" class="widget widget_text mt--30 mt--first--0 ghacks-links--nounderline"><h3 class="heading--tiny border--bottom--gray mb--10 pb--6">Ghacks Newsletter Sign Up</h3> <div class="textwidget"><p>Please click on the following link to open the newsletter signup page: <a href="http://eepurl.com/dp_1rj" rel="nofollow external noopener noreferrer" data-mce-href="http://eepurl.com/dp_1rj" data-wpel-link="external" target="_blank">Ghacks Newsletter Sign up</a></p>
</div>
</div><div id="ghacks_ad_code-7" class="widget ghacks_ad_code mt--30 mt--first--0 ghacks-links--nounderline"><h3 class="heading--tiny border--bottom--gray mb--10 pb--6">Advertisement</h3><div class='ghacks-ad' data-width='336' data-height='336'><div class="center-box-banner">
<div id='snhb-sidebar_01-0'></div>
</div>
</div></div><div id="ghacks_taxonomy_popular-2" class="widget widget_ghacks_taxonomy_popular mt--30 mt--first--0 ghacks-links--nounderline"><h3 class="heading--tiny border--bottom--gray mb--10 pb--6">Popular Posts</h3>
<ul>
<li>
<a href="https://www.ghacks.net/2021/10/27/defenderui-manage-microsoft-defender-with-this-profile-based-third-party-app/" data-wpel-link="internal">DefenderUI: manage Microsoft Defender with this profile-based third-party app</a>
<div class="popular-comments">
<span class="comments-number comments-number-medium">55</span>
</div>
</li>
<li>
<a href="https://www.ghacks.net/2022/02/16/take-control-of-windows-updating-and-upgrading-with-incontrol/" data-wpel-link="internal">Take control of Windows updating and upgrading with InControl</a>
<div class="popular-comments">
<span class="comments-number comments-number-medium">52</span>
</div>
</li>
<li>
<a href="https://www.ghacks.net/2021/07/07/pdf-reader-sumatrapdf-3-3-has-been-released/" data-wpel-link="internal">PDF Reader SumatraPDF 3.3 has been released</a>
<div class="popular-comments">
<span class="comments-number comments-number-medium">48</span>
</div>
</li>
<li>
<a href="https://www.ghacks.net/2021/06/07/notepad-8-0-has-been-released/" data-wpel-link="internal">Notepad++ 8.0 has been released</a>
<div class="popular-comments">
<span class="comments-number comments-number-medium">39</span>
</div>
</li>
<li>
<a href="https://www.ghacks.net/2021/11/21/7-zip-21-05-first-stable-version-of-2021-released/" data-wpel-link="internal">7-Zip 21.05: first stable version of 2021 released</a>
<div class="popular-comments">
<span class="comments-number comments-number-medium">38</span>
</div>
</li>
</ul>
</div><div id="ghacks_ad_code-8" class="widget ghacks_ad_code mt--30 mt--first--0 ghacks-links--nounderline"><h3 class="heading--tiny border--bottom--gray mb--10 pb--6">Advertisement</h3><div class='ghacks-ad' data-width='336' data-height='336'><div class="center-box-banner">
<div id='snhb-sidebar_02-0'></div>
</div>
</div></div><div id="ghacks_taxonomy_last_news-2" class="widget widget_ghacks_taxonomy_last_news mt--30 mt--first--0 ghacks-links--nounderline"><h3 class="heading--tiny border--bottom--gray mb--10 pb--6">Recently Updated</h3>
<ul>
<li>
<a href="https://www.ghacks.net/2009/12/16/christmas-giveaway-paragon-drive-backup-2010-special-edition/" data-wpel-link="internal">Paragon Drive Backup Download Paragon Backup Software</a>
<div class="popular-comments">
Published in: December 16, 2009 11:05 am | Updated in: April 10, 2022 7:04 am
</div>
</li>
<li>
<a href="https://www.ghacks.net/2022/04/09/bloatware-removal-tool-remove-pre-installed-windows-applications-and-more/" data-wpel-link="internal">Bloatware Removal Tool: remove pre-installed Windows applications and more</a>
<div class="popular-comments">
Published in: April 9, 2022 10:19 am | Updated in: April 9, 2022 10:19 am
</div>
</li>
<li>
<a href="https://www.ghacks.net/2022/04/08/microsoft-powertoys-could-soon-get-a-mac-os-inspired-peek-file-preview-feature/" data-wpel-link="internal">Microsoft PowerToys could soon get a Mac OS inspired Peek file preview feature</a>
<div class="popular-comments">
Published in: April 8, 2022 6:54 am | Updated in: April 8, 2022 6:54 am
</div>
</li>
<li>
<a href="https://www.ghacks.net/2022/04/04/faststone-image-viewer-7-6-improved-performance-and-new-rating-system/" data-wpel-link="internal">FastStone Image Viewer 7.6: improved performance and new rating system,</a>
<div class="popular-comments">
Published in: April 4, 2022 11:22 am | Updated in: April 4, 2022 11:22 am
</div>
</li>
<li>
<a href="https://www.ghacks.net/2022/04/04/recover-windows-and-program-passwords-with-extpassword/" data-wpel-link="internal">Recover Windows and program passwords with ExtPassword</a>
<div class="popular-comments">
Published in: April 4, 2022 7:09 am | Updated in: April 4, 2022 7:09 am
</div>
</li>
</ul>
</div><div id="ghacks_ad_code-9" class="widget ghacks_ad_code mt--30 mt--first--0 ghacks-links--nounderline"><h3 class="heading--tiny border--bottom--gray mb--10 pb--6">Advertisement</h3><div class='ghacks-ad' data-width='336' data-height='336'><div class="center-box-banner">
<div id='snhb-sidebar_03-0'></div>
</div>
</div></div> </div>
</div>
</div>

<script>
  jQuery(document).ready(function(){
    var swiper = new Swiper('.swiper-container', {
      slidesPerView: 1,
      slidesPerGroup:1,
      spaceBetween: 20,
      //loop:true,
      //centeredSlides: true,
      pagination: {
      el: '.swiper-pagination',
      clickable: true,
      },
      pagination: {
      el: '.swiper-pagination',
      clickable: true,
      },
      breakpoints: {
          991: {
            slidesPerView: 3,
            slidesPerGroup:3,
            spaceBetween: 20,
            autoHeight: true,
          }
        }
    });
    var count_img = 1;
    var count_picture = 1;
    jQuery('.ghacks-content .user-content p img').each(function() {
        jQuery(this).attr('data-rv-in-image','rv-in-image-'+count_img);
        count_img++;
    });
    jQuery('.ghacks-content .user-content p picture').each(function() {
        jQuery(this).attr('data-rv-in-image','rv-in-image-'+count_picture);
        count_picture++;
    });
  });
  </script>
<div class='mt--30' id='site-footer' style="margin:30px 0 0 0;">
<div class='bg--darkGray color--white pt--40 pb--40' style="background-color:#3B3B3B; padding-top:40px; padding-bottom:40px;color:#ffffff;">
<div class='container'>
<div class='row gutter--large cols-footer' style="display: flex;">
<div class='col-half' style="padding-right: 0.5rem;padding-left: 0.5rem;">
<h4 class='heading--tiny mb--10' style="font-size:14px;font-weight:600;text-transform:uppercase;">About gHacks</h4>
<p class='text--small' style="font-size: 14px;">
Ghacks is a technology news blog that was founded in 2005 by Martin Brinkmann. It has since then become one of the most popular tech news sites on the Internet with five authors and regular contributions from freelance writers.
</p>
</div>
<div class='col-quarter ghacks-links--nounderline mt--xs--40' style="padding-right: 0.5rem;padding-left: 0.5rem;">
<ul class='top-level'>
<li>
<a href="https://www.ghacks.net/about-us/" data-wpel-link="internal">About</a> </li>
<li>
<a href="https://www.ghacks.net/ghacksnet-feed-list/" data-wpel-link="internal">RSS Feeds</a> </li>
<li>
<span data-loc='aHR0cHM6Ly9oZWxsby5zb2Z0b25pYy5jb20vbGVnYWwtaW5mb3JtYXRpb24v'>Legal Information</span> </li>
<li>
<span data-loc='aHR0cHM6Ly9oZWxsby5zb2Z0b25pYy5jb20vdGVybXMtb2YtdXNlLw=='>Terms of use</span> </li>
<li>
<span data-loc='aHR0cHM6Ly9oZWxsby5zb2Z0b25pYy5jb20vcHJpdmFjeS1wb2xpY3kv'>Privacy Policy</span> </li>
<li>
<span data-loc='aHR0cHM6Ly9oZWxsby5zb2Z0b25pYy5jb20vY29va2llcy1wb2xpY3kv'>Cookie Policy</span> </li>
<li>
<a href="#"><span onclick="Didomi.preferences.show();return false;">Cookie settings</span></a> </li>
<li>
<a href="/cdn-cgi/l/email-protection#076663716275736e74627574477468617368696e642964686a">Advertise with Us</a> </li>
</ul>
</div>
<div class='col-quarter ghacks-links--nounderline mt--xs--40' style="padding-right: 0.5rem;padding-left: 0.5rem;">
<ul class='top-level'>
<li>
<a href="https://www.ghacks.net/author/martin/" data-wpel-link="internal">Martin Brinkmann</a>
</li>
<li>
<a href="https://www.ghacks.net/author/miketur/" data-wpel-link="internal">Mike Turcotte</a>
</li>
<li>
<a href="https://www.ghacks.net/author/ashwin/" data-wpel-link="internal">Ashwin</a>
</li>
<li>
<a href="https://www.ghacks.net/we-use/" data-wpel-link="internal">We Use</a>
</li>
</ul>
</div>
</div>
</div>
</div>
<div class='bg--black color--white pt--6 pb--6 text--center' style="background-color:#272727; padding: 6px 0; text-align:center; color:#ffffff;">
<div class='container'>
<div class='opacity--60 text--tiny' style="font-size: 12px;opacity:0.6;">The name and logo of Ghacks are copyrights or trademarks of SOFTONIC INTERNATIONAL S.A.</div>
<div class='opacity--60 text--tiny' style="font-size: 12px;opacity:0.6;">Copyright SOFTONIC INTERNATIONAL S.A. © 2005- 2022 - All rights reserved</div>

</div>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
  jQuery(document).ready(function() {
  //search in mobile
    jQuery('.open-custom-search').click(function(){
      jQuery(this).toggleClass('show');
      jQuery('.top-search-box').toggleClass('show');
      setTimeout(function(){ jQuery('#search-site').focus(); }, 300);
    });

  //ad show in scroll
  jQuery(window).scroll(function() {    
    var scroll = jQuery(window).scrollTop();

    if (scroll >= 71.2) {
      jQuery('.banner-box-scroll').addClass('show');
    } else {
      jQuery('.banner-box-scroll').removeClass('show');
    }
  });

  if(jQuery('#snhb-sidebar_03-0').length){
    jQuery(window).on('scroll', function () {
	    var scrollTop     = jQuery(window).scrollTop(),
	        elementOffset = jQuery('#snhb-sidebar_03-0').offset().top,
	        distance      = (elementOffset - scrollTop);

	    
	        if (scrollTop > distance) {
	          
	          if (jQuery('#snhb-sidebar_03-0 > div').is(':empty')){
			        
			        jQuery('.ghacks_ad_code').css('position','static');
			    } else {
			        
			   }

	        } else {
	          
	        }
	    
	    
	  });
  }
 

  /*jQuery( window ).on( "load", function() {

	  if (jQuery('#snhb-sidebar_03-0').is(':empty')){
	        console.log('no ads loaded');
	        jQuery('.ghacks_ad_code').css('position','static');
	    } else {
	        console.log('ads loaded');
	   }

  });*/

});
</script>
</main>
<button type="button" aria-controls="rmp-container-176613" aria-label="Menu Trigger" id="rmp_menu_trigger-176613" destination="" class="rmp_menu_trigger rmp-menu-trigger-boring">
<span class="rmp-trigger-box">
<span class="responsive-menu-pro-inner"></span>
</span>
</button>
<div id="rmp-container-176613" class="rmp-container rmp-container rmp-slide-left">
<div id="rmp-menu-title-176613" class="rmp-menu-title">
<a href="" target="_self" id="rmp-menu-title-link" data-wpel-link="internal">
<img class="rmp-menu-title-image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" alt="" title="" width="100" height="100" data-lazy-src="https://www.ghacks.net/wp-content/uploads/2020/11/ghack-logo-menu.png" /><noscript><img class="rmp-menu-title-image" src="https://www.ghacks.net/wp-content/uploads/2020/11/ghack-logo-menu.png" alt="" title="" width="100" height="100" /></noscript> <span></span>
</a>
</div>
<div id="rmp-menu-wrap-176613" class="rmp-menu-wrap"><ul id="rmp-menu-176613" class="rmp-menu" role="menubar" aria-label="Default Menu"><li id="rmp-menu-item-170930" class=" menu-item menu-item-type-post_type menu-item-object-page menu-item-home rmp-menu-item rmp-menu-top-level-item" role="none"><a href="https://www.ghacks.net/" class="rmp-menu-item-link" role="menuitem" data-wpel-link="internal">Home</a></li><li id="rmp-menu-item-93262" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children rmp-menu-item rmp-menu-top-level-item" role="none"><a href="https://www.ghacks.net/category/windows/" class="rmp-menu-item-link" role="menuitem" data-wpel-link="internal">Windows</a></li><li id="rmp-menu-item-139904" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children rmp-menu-item rmp-menu-top-level-item" role="none"><a href="https://www.ghacks.net/category/linux/" class="rmp-menu-item-link" role="menuitem" data-wpel-link="internal">Linux</a></li><li id="rmp-menu-item-93261" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children rmp-menu-item rmp-menu-top-level-item" role="none"><a href="https://www.ghacks.net/category/software/" class="rmp-menu-item-link" role="menuitem" data-wpel-link="internal">Software</a></li><li id="rmp-menu-item-93263" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children rmp-menu-item rmp-menu-top-level-item" role="none"><a href="https://www.ghacks.net/category/firefox/" class="rmp-menu-item-link" role="menuitem" data-wpel-link="internal">Firefox</a></li><li id="rmp-menu-item-93264" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children rmp-menu-item rmp-menu-top-level-item" role="none"><a href="https://www.ghacks.net/category/google-chrome-browsing/" class="rmp-menu-item-link" role="menuitem" data-wpel-link="internal">Chrome</a></li><li id="rmp-menu-item-139911" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children rmp-menu-item rmp-menu-top-level-item" role="none"><a href="https://www.ghacks.net/category/the-web/" class="rmp-menu-item-link" role="menuitem" data-wpel-link="internal">Internet</a></li><li id="rmp-menu-item-139910" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children rmp-menu-item rmp-menu-top-level-item" role="none"><a href="https://www.ghacks.net/category/mobile-computing/" class="rmp-menu-item-link" role="menuitem" data-wpel-link="internal">Mobile Computing</a></li><li id="rmp-menu-item-139958" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children rmp-menu-item rmp-menu-top-level-item" role="none"><a href="https://www.ghacks.net/category/companies/" class="rmp-menu-item-link" role="menuitem" data-wpel-link="internal">Companies</a></li><li id="rmp-menu-item-122011" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children rmp-menu-item rmp-menu-top-level-item" role="none"><a href="https://www.ghacks.net/category/email/" class="rmp-menu-item-link" role="menuitem" data-wpel-link="internal">Email</a></li><li id="rmp-menu-item-139959" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children rmp-menu-item rmp-menu-top-level-item" role="none"><a href="https://www.ghacks.net/category/misc/" class="rmp-menu-item-link" role="menuitem" data-wpel-link="internal">Misc</a></li><li id="rmp-menu-item-113697" class=" menu-item menu-item-type-custom menu-item-object-custom rmp-menu-item rmp-menu-top-level-item" role="none"><a href="https://deals.ghacks.net/" class="rmp-menu-item-link" role="menuitem" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">Deals</a></li></ul></div> </div>
<script type="text/javascript">
          document.addEventListener("DOMContentLoaded", function(event) {
            var submitButton = document.getElementById('submit');
            submitButton.addEventListener('click', function(event) {
              var privacyBox = document.querySelector('.privacyBox');
              if (!privacyBox.checked) {
                event.preventDefault();
                alert('Please agree to our privacy terms by checking the box to post a comment');
                return false;
              }
            });
          });
        </script>
<script type='text/javascript' id='geoip-detect-js-js-extra'>
/* <![CDATA[ */
var geoip_detect = {"options":{"ajaxurl":"https:\/\/www.ghacks.net\/wp-admin\/admin-ajax.php","default_locales":["en","en"],"do_body_classes":false,"do_shortcodes":false,"cookie_name":"geoip-detect-result","cookie_duration_in_days":1}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ghacks.net/wp-content/plugins/geoip-detect/js/dist/frontend.js?ver=5.0.0' id='geoip-detect-js-js' defer></script>
<script type='text/javascript' src='https://www.ghacks.net/wp-content/plugins/my-custom-functionality-master/assets/js/swiper.min.js?ver=9.9.0' id='swiper-js' defer></script>
<script type='text/javascript' id='rmp_menu_scripts-js-extra'>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</script>
<script type='text/javascript' src='https://www.ghacks.net/wp-content/plugins/responsive-menu/v4.0.0/assets/js/rmp-menu.js?ver=4.1.7' id='rmp_menu_scripts-js' defer></script>
<script type='text/javascript' id='ghacks-scripts-js-extra'>
/* <![CDATA[ */
var ghacks = {"adBlockerMessage":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ghacks.net/wp-content/themes/new-ghacks-preview/scripts.js?ver=1.2.3.4.26' id='ghacks-scripts-js' defer></script>
<script type='text/javascript' src='https://www.ghacks.net/wp-includes/js/comment-reply.min.js?ver=5.8.4' id='comment-reply-js' defer></script>
<script type='text/javascript' src='https://www.ghacks.net/wp-includes/js/wp-embed.min.js?ver=5.8.4' id='wp-embed-js' defer></script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.ghacks.net/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script></body>
</html>
