<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1"><link rel="profile" href="https://gmpg.org/xfn/11"><meta name="referrer" content="no-referrer-when-downgrade" /><meta name="p:domain_verify" content="8a2e6b093ae4490f91654376b226e667" /> <a href="https://plus.google.com/107836925448900328328/" rel="publisher"></a><meta name="google-site-verification" content="n2jzjIqW7RNyDoySWmRTkpddRTo__4of8pKAyeOjNiA" /><link rel='search' type='application/opensearchdescription+xml' title='ghacks.net' href='https://cdn.ghacks.net/opensearch.xml'><title>A look at FocusWriter distraction free text editor on GNU/Linux - gHacks Tech News</title><style id="rocket-critical-css">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</style><meta name="description" content="FocusWriter is a cross-platform tool available to be easily installed on multiple GNU/Linux distributions, as well as Windows and Mac OS." /><link rel="canonical" href="https://www.ghacks.net/2018/05/06/a-look-at-focuswriter-distraction-free-text-editor-on-gnu-linux/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="A look at FocusWriter distraction free text editor on GNU/Linux - gHacks Tech News" /><meta property="og:description" content="FocusWriter is a cross-platform tool available to be easily installed on multiple GNU/Linux distributions, as well as Windows and Mac OS." /><meta property="og:url" content="https://www.ghacks.net/2018/05/06/a-look-at-focuswriter-distraction-free-text-editor-on-gnu-linux/" /><meta property="og:site_name" content="gHacks Technology News" /><meta property="article:publisher" content="https://www.facebook.com/ghacksnet" /><meta property="article:section" content="Linux" /><meta property="article:published_time" content="2018-05-06T09:22:54+02:00" /><meta property="og:image" content="https://cdn.ghacks.net/wp-content/uploads/2018/05/focus-writer.jpg" /><meta property="og:image:secure_url" content="https://cdn.ghacks.net/wp-content/uploads/2018/05/focus-writer.jpg" /><meta property="og:image:width" content="1144" /><meta property="og:image:height" content="452" /><meta property="og:image:alt" content="focus writer" /> <script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/www.ghacks.net\/","sameAs":["https:\/\/www.facebook.com\/ghacksnet"],"@id":"https:\/\/www.ghacks.net\/#organization","name":"Ghacks Technology News","logo":"http:\/\/www.ghacks.net\/wp-content\/uploads\/2015\/03\/ghacks-technology-news.jpg"}</script> <link rel='dns-prefetch' href='//cdn.ghacks.net' /><link rel='dns-prefetch' href='//pagead2.googlesyndication.com' /><link rel='dns-prefetch' href='//www.googletagservices.com' /><link rel="alternate" type="application/rss+xml" title="gHacks Technology News &raquo; Feed" href="https://www.ghacks.net/feed/" /><link rel="alternate" type="application/rss+xml" title="gHacks Technology News &raquo; Comments Feed" href="https://www.ghacks.net/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="gHacks Technology News &raquo; A look at FocusWriter distraction free text editor on GNU/Linux Comments Feed" href="https://www.ghacks.net/2018/05/06/a-look-at-focuswriter-distraction-free-text-editor-on-gnu-linux/feed/" /><link rel='preload' id='cookie-notice-front-css' href='https://cdn.ghacks.net/wp-content/plugins/cookie-notice/css/front.min.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='wprc-style-css' href='https://www.ghacks.net/wp-content/cache/min/1/wp-content/plugins/report-content/static/css/styles-d7bb4f907a97ce82b6e0e6e6910286d8.css' as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" type='text/css' media='all' /><link rel='preload' id='dlm-frontend-css' href='https://www.ghacks.net/wp-content/cache/min/1/wp-content/plugins/download-monitor/assets/css/frontend-b261307d89a4e14e8effccc50a11e4ff.css' as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" type='text/css' media='all' /><link rel='preload' id='ghacks-style-css' href='https://www.ghacks.net/wp-content/cache/min/1/wp-content/themes/new-ghacks-preview/style-5685282605538f241454946a138b2caf.css' as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" type='text/css' media='all' /><link rel='preload' id='rating_style-css' href='https://www.ghacks.net/wp-content/cache/min/1/wp-content/plugins/all-in-one-schemaorg-rich-snippets/css/jquery.rating-267b5ea18d0f55da804ae9be29304802.css' as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" type='text/css' media='all' /> <script type='text/javascript' src='https://cdn.ghacks.net/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-1.12.4.js'></script> <script type='text/javascript' src='https://cdn.ghacks.net/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-migrate.min-1.4.1.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var wprcajaxhandler = {"ajaxurl":"https:\/\/www.ghacks.net\/wp-admin\/admin-ajax.php"}; /* ]]> */</script> <script type='text/javascript' src='https://cdn.ghacks.net/wp-content/plugins/report-content/static/js/scripts.js' defer></script> <script type='text/javascript' src='https://cdn.ghacks.net/wp-content/plugins/all-in-one-schemaorg-rich-snippets/js/jquery.rating.min.js' defer></script> <link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ghacks.net/xmlrpc.php?rsd" /><link rel='shortlink' href='https://www.ghacks.net/?p=143645' /> <script type="text/javascript">var ajaxurl = "https://www.ghacks.net/wp-admin/admin-ajax.php"</script><script>/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script> <script async src='//www.googletagservices.com/tag/js/gpt.js'></script> <script>var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];

      googletag.cmd.push(function() {
        googletag.defineSlot('/22152718/ghacks_middle_300x600', [300, 600], 'div-gpt-ad-1424293853434-0').addService(googletag.pubads());
        googletag.defineSlot('/22152718/ghacks_middle-snd_300x250', [300, 250], 'div-gpt-ad-1431549664776-0').addService(googletag.pubads());
        googletag.defineSlot('/22152718/ghacks_middle-trd_300x250', [300, 250], 'div-gpt-ad-1431549718596-0').addService(googletag.pubads());
        googletag.pubads().enableSingleRequest();
        googletag.pubads().collapseEmptyDivs();
        googletag.enableServices();
      });</script> </head><body><div class='mb--30 ghacks-header'><div class='bg--darkGray pt--10 pb--10'><div class='container'><div class='row middle-xs between-xs nocol'><div class='ghacks-header-logo'> <a href="https://www.ghacks.net" class="no-underline" data-wpel-link="internal"> <span style='flex-wrap:nowrap' class="row middle-xs ghacks-logo ghacks-logo--light ghacks-logo--medium"> <span class='mr--10'><svg class="" style=" " width="42" height="42" viewBox="0 0 42 42" fill="#F3B434"><ellipse cx="21" cy="20.9" rx="20.7" ry="20.9" fill="#FFF"></ellipse><path d="M41.6 20.7C31 33.8 18.1 36.4 2 29.3 3.6 32.8 6 35.8 9.1 38 20.8 40.9 29.6 39.1 37.5 33.3 40.1 29.9 41.6 25.6 41.6 20.9 41.6 20.8 41.6 20.8 41.6 20.7L41.6 20.7Z"></path><path d="M12.3 19.4C8.7 19.4 4.8 18.5 0.7 17.1 0.4 18.3 0.3 19.6 0.3 20.9 0.3 21.9 0.4 22.8 0.5 23.7 4.6 25 8.6 25.8 12.4 26 12.4 26 11.3 22.9 12.3 19.4L12.3 19.4Z"></path><path d="M28.6 15.7C31.2 18.1 31.6 21.9 31.6 21.9 34.9 20 37.9 17.5 40.6 14.4 39.8 12.1 38.7 10 37.3 8.1 34.7 11.4 31.8 14 28.6 15.7L28.6 15.7Z"></path><path d="M28.2 20C28 18.7 27.2 17.7 26.2 17 24.7 16 22.8 15.6 20.7 16 18.5 16.4 16.6 17.8 15.8 19.4 15.3 20.4 15.1 21.4 15.3 22.5 15.6 24 16.6 25.2 18.1 26 18.1 26 18.1 26 18.1 26 17.9 27.2 17.2 28.4 17.2 28.4 17.2 28.4 19.6 28.3 21.1 26.7 21.6 26.7 22.2 26.6 22.8 26.5 24.6 26.1 26.1 25.2 27.1 24 28 22.8 28.5 21.4 28.2 20L28.2 20Z"></path><path d="M31.4 3.6C31.5 3.4 31.6 3.3 31.7 3.1 30.1 2.1 28.4 1.3 26.5 0.8 21.4 6.4 14.9 7.7 6.9 5.6 5.4 7 4.2 8.6 3.2 10.3 13.4 14.3 25 12.7 31.4 3.6L31.4 3.6Z"></path></svg></span><div> <span class='color--orange'>g</span>hacks.<span class='color--orange'>net</span></div> </span> </a></div><div class='show-sm-up ml--20 mr--20'><div class='ghacks-ad' data-width="728" data-height='90'><div><style type="text/css">.adslot_1{width:320px;height:100px}@media (min-width:501px){.adslot_1{width:468px!important;height:60px!important}}@media (min-width:1001px){.adslot_1{width:728px!important;height:90px!important}}</style> <ins class="adsbygoogle adslot_1" style="display:inline-block;" data-ad-client="ca-pub-5406364303442190" data-ad-slot="6144069130"> </ins></div></div></div><div id='mobile-nav-trigger' class='show-sm-down'> <span></span> <span></span> <span></span></div></div></div></div><div class='top-navigation'><div class='bg--black pt--10 color--white'><div class='container'><div class='row noflex'><ul class='top-level'><li> <a class="" href='https://www.ghacks.net/'>Home</a></li><li> <a class="" href='https://www.ghacks.net/category/windows/'>Windows</a></li><li> <a class="" href='https://www.ghacks.net/category/linux/'>Linux</a></li><li> <a class="" href='https://www.ghacks.net/category/software/'>Software</a></li><li> <a class="" href='https://www.ghacks.net/category/firefox/'>Firefox</a></li><li> <a class="" href='https://www.ghacks.net/category/google-chrome-browsing/'>Chrome</a></li><li> <a class="" href='https://www.ghacks.net/category/the-web/'>Internet</a></li><li> <a class="" href='https://www.ghacks.net/category/mobile-computing/'>Mobile Computing</a></li><li> <a class="" href='https://www.ghacks.net/category/companies/'>Companies</a></li><li> <a class="" href='https://www.ghacks.net/category/email/'>Email</a></li><li> <a class="" href='https://www.ghacks.net/category/misc/'>Misc</a></li><li> <a class="" href='https://deals.ghacks.net/'>Deals</a></li></ul></div></div></div></div></div><div class='container'><div class='ghacks-sidebared-content'><div class='ghacks-content'><div class="post-list mt--60 mt--first--0 post-143645 post type-post status-publish format-standard has-post-thumbnail hentry category-linux"><h1 class='heading--large'>A look at FocusWriter distraction free text editor on GNU/Linux</h1><div class='opacity--90 text--small ghacks-links ghacks-links--smallunderline mt--10 mb--20'> by <a href="https://www.ghacks.net/author/miketur/" data-wpel-link="internal">Mike Turcotte-McCusker</a> on May 06, 2018 in <a href="https://www.ghacks.net/category/linux/" rel="category tag" data-wpel-link="internal">Linux</a> - <a href="https://www.ghacks.net/2018/05/06/a-look-at-focuswriter-distraction-free-text-editor-on-gnu-linux/#comments" data-wpel-link="internal">3 comments</a></div><div class='user-content'><p>Writing has always been something I enjoyed throughout my life, and nowadays I practically write for a living. You’d think that being a professional writer, I might have some kind of hyper-focus when I sit down to write...</p><p>But sadly, I openly admit to being easily distracted. Thankfully, there are different tools I utilize sometimes to help mitigate that issue; one such tool being <a href="https://gottcode.org/focuswriter/" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">FocusWriter</a>.</p><p>FocusWriter is a cross-platform tool available to be easily installed on multiple GNU/Linux distributions, as well as Windows and Mac OS.</p><h3>Installation</h3><p>Installation in GNU/Linux is fairly straightforward, with many distributions carrying FocusWriter in their repositories, as well as Debian, Fedora, and OpenSUSE users can get the program <a href="https://gottcode.org/focuswriter/" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">from here</a>.</p><p>Windows and Mac users can download the text editor from the official project website as well to run or install it on their devices.</p><h3>Features</h3><p><img class="alignnone size-full wp-image-143646" src="https://cdn.ghacks.net/wp-content/uploads/2018/05/focus-writer.jpg" alt="focus writer" width="1144" height="452" /></p><p>FocusWriter isn’t super powerful, nor is it deeply extensible, but it’s not entirely special feature-less either, with the FocusWriter website listing its features as:</p><ul><li>TXT, basic RTF, Docx, basic ODT file support</li><li>Timers and alarms</li><li>Daily goals</li><li>Fully customizable themes</li><li>Typewriter sound effects (optional)</li><li>Auto-save (optional)</li><li>Live statistics (optional)</li><li>Spell-checking (optional)</li><li>Multi-document support</li><li>Sessions</li><li>Portable mode (optional)</li><li>Translated into over 20 languages</li></ul><p>The program opens the editing interface in fullscreen on start. All you see on start is a blank text document and a wooden background; no menus, buttons or other interface elements that may get in your way.</p><p>How do you interact with the program then? How do you exit it, load documents, or change some of the default options? All you need to do is move the mouse cursor to the top of the screen and move it back down a bit afterward.</p><p>Doing so displays the menu bar which you may use to interact with the application. You find save and load options there, options to change the format of text, or switch to a different theme. All of these options are accessible through keyboard shortcuts as well. While you need to know what those are before you may use them, it is usually faster to use the keyboard than moving the mouse to display the menu and to select the option from there.</p><h3>My Experience with FocusWriter</h3><p>FocusWriter is very simple and straightforward as you can see, but it serves its purpose and it serves it well.</p><p>One of the biggest helpful things for me when it comes to really buckling down and focusing on writing, is to remove myself and my usual distractions. So, I’ll change rooms, and then I’ll break out FocusWriter to do the same thing so to speak, inside my screen.</p><p>One of the downsides to FocusWriter though from my own perspective, is the lack of formatting tools.</p><p>Granted, if you were to put too many things on the screen at once, it detracts from the very principle of the application. However, I think that at least adding the absolute basics, like text position, font manipulation, and bullet lists, would be extremely helpful. Just my two copper however, and I will still recommend anyone who may find this sort of thing useful, check it out.</p><p><strong>Now you</strong>: Are there tools you use, to help keep yourself from losing focus or increasing productivity? Let us know in the comments!</p><div id="snippet-box" class="snippet-type-10" style="background:#F5F5F5; color:#333333; border:1px solid #ACACAC;"><div class="snippet-title" style="background:#E4E4E4; color:#333333; border-bottom:1px solid #ACACAC;">Summary</div><div itemscope itemtype="http://schema.org/Article"><div class="snippet-image" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><img width="180" src="https://cdn.ghacks.net/wp-content/uploads/2018/05/focus-writer.jpg" alt="A look at FocusWriter distraction free text editor on GNU/Linux" /><meta itemprop="url" content="https://cdn.ghacks.net/wp-content/uploads/2018/05/focus-writer.jpg"><meta itemprop="width" content="800"><meta itemprop="height" content="800"></div><div class="aio-info"><div class="snippet-label-img">Article Name</div><div class="snippet-data-img"><span itemprop="headline">A look at FocusWriter distraction free text editor on GNU/Linux</span></div><div class="snippet-clear"></div><div class="snippet-label-img">Description</div><div class="snippet-data-img"><span itemprop="description">FocusWriter is a cross-platform tool available to be easily installed on multiple GNU/Linux distributions, as well as Windows and Mac OS.</span></div><div class="snippet-clear"></div><div class="snippet-label-img">Author</div><div class="snippet-data-img" itemprop="author" itemscope itemtype="https://schema.org/Person"> <span itemprop="name">Mike Turcotte-McCusker</span></div><div class="snippet-clear"></div><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div class="snippet-label-img">Publisher</div><div class="snippet-data-img"> <span itemprop="name">Ghacks Technology News</span></div><div class="snippet-clear"></div><div class="snippet-label-img">Logo</div><div class="snippet-data-img publisher-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><img width="180" src="https://cdn.ghacks.net/wp-content/uploads/2018/05/focus-writer.jpg" /><meta itemprop="url" content="https://cdn.ghacks.net/wp-content/uploads/2018/05/focus-writer.jpg"><meta itemprop="width" content="800"><meta itemprop="height" content="800"></div></div><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.ghacks.net/2018/05/06/a-look-at-focuswriter-distraction-free-text-editor-on-gnu-linux/" /><meta itemprop="datePublished" content="2018-05-06T09:22:54+00:00" /><meta itemprop="dateModified" content="2018-05-06T09:22:54+00:00" /></div></div></div><div class="snippet-clear"></div><div class="wprc-container yellow-colorscheme"> <button type="button" class="wprc-switch">Report errors / request updates</button><div class="wprc-content"><div class="wprc-message"></div><div class="wprc-form"><div class="left-section"><li class="list-item-reason"> <label for="input-reason-143645">Issue: <span class="required-sign">*</span></label><br /> <select id="input-reason-143645" class="input-reason"><option>Broken Links</option><option>Request Update</option><option>Other</option> </select></li><li class="list-item-name"> <label for="input-name-143645"> Your Name: </label><br /> <input type="text" id="input-name-143645" class="input-name wprc-input" /></li><li class="list-item-email"> <label for="input-email-143645"> Your Email: </label><br /> <input type="text" id="input-email-143645" class="input-email wprc-input" /></li></div><div class="right-section"><li class="list-item-details"> <label for="input-details-143645"> Details: <span class="required-sign">*</span> </label><br /><textarea placeholder="All submissions are read but not replied to unless explicitly requested in Details. Thank you for your submission!" id="input-details-143645" class="input-details wprc-input"></textarea></li></div><div class="clear"></div> <input type="hidden" class="post-id" value="143645"> <button type="button" class="wprc-submit">Submit Report</button> <img class="loading-img" style="display:none;" src="https://cdn.ghacks.net/wp-content/plugins/report-content/static/img/loading.gif" /></div></div></div><hr /></div><meta itemprop="commentCount" content="3"><meta itemprop="dateUpdated" content=""><meta itemprop="discussionURL" content="https://www.ghacks.net/2018/05/06/a-look-at-focuswriter-distraction-free-text-editor-on-gnu-linux/"><meta itemprop="inLanguage" content="en"><meta itemprop="timeRequired" content="P3M"></div><div class='show-lg-only mt--20'><div class='ghacks-ad' data-width="728" data-height='90'> <ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-format="fluid" data-ad-layout="in-article" data-ad-client="ca-pub-5406364303442190" data-ad-slot="6082087934"></ins></div></div><div class='border--top--gray pt--40 mt--40'><h3 class='heading--small mb--20'>We need your help</h3><div class='user-content'><p> Advertising revenue is falling fast across the Internet, and independently-run sites like Ghacks are hit hardest by it. The advertising model in its current form is coming to an end, and we have to find other ways to continue operating this site.</p><p> We are committed to keeping our content free and independent, which means no paywalls, no sponsored posts, no annoying ad formats (video ads) or subscription fees.</p><p> If you like our content, and would like to help, please consider making a contribution:</p></div><div class='mt--20 row nocol middle-xs'> <a class="mr--20" href="https://www.patreon.com/bePatron?c=150037" data-wpel-link="external" target="_blank" rel="external noopener noreferrer"><svg class="" style=" " width="217" height="51" viewBox="0 0 217 51" version="1.1"> <g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"> <g id="Group"> <rect id="Rectangle" fill="#F96854" x="0" y="0" width="217" height="51"></rect> <path d="M55.3292002,26.5979999 C56.6724002,26.8023999 57.4608002,27.7075999 57.4608002,29.0799999 C57.4608002,30.7152 56.3074002,32 53.9422002,32 L49.0804,32 L49.0804,21.6339997 L53.7524002,21.6339997 C56.1176002,21.6339997 57.1980002,22.7873998 57.1980002,24.3057998 C57.1980002,25.3861998 56.5410002,26.2767999 55.3292002,26.5979999 Z M53.0954001,23.3713998 L51.5478001,23.3713998 L51.5478001,25.8971998 L53.0954001,25.8971998 C54.2050002,25.8971998 54.6284002,25.3277998 54.6284002,24.6269998 C54.6284002,23.8969998 54.1612002,23.3713998 53.0954001,23.3713998 Z M53.2560001,30.2626 C54.3802002,30.2626 54.8912002,29.6639999 54.8912002,28.8755999 C54.8912002,28.0725999 54.3510002,27.5323999 53.3144001,27.5323999 L51.5478001,27.5323999 L51.5478001,30.2626 L53.2560001,30.2626 Z M62.5270014,30.175 L62.5270014,27.6053999 L66.9070015,27.6053999 L66.9070015,25.7949998 L62.5270014,25.7949998 L62.5270014,23.4589998 L67.1552015,23.4589998 L67.1552015,21.6339997 L60.0596014,21.6339997 L60.0596014,32 L67.2574015,32 L67.2574015,30.175 L62.5270014,30.175 Z M74.3384028,32.2482 C76.9080028,32.2482 78.5140029,30.8466 79.0104029,28.6565999 L76.5138028,28.1163999 C76.3094028,29.4595999 75.5356028,30.248 74.3822028,30.248 C72.7470027,30.248 71.8126027,28.8755999 71.8126027,26.8169999 C71.8126027,24.6999998 72.7324027,23.3713998 74.3092028,23.3713998 C75.5502028,23.3713998 76.3094028,24.1743998 76.4554028,25.5467998 L78.9520029,25.1087998 C78.6746029,22.8457998 77.0102028,21.3857997 74.3676028,21.3857997 C71.2140027,21.3857997 69.2868026,23.5611998 69.2868026,26.8315999 C69.2868026,30.102 71.0534027,32.2482 74.3384028,32.2482 Z M85.9746041,32.2482 C82.864804,32.2482 80.864604,30.1458 80.864604,26.8169999 C80.864604,23.4735998 82.864804,21.3857997 85.9746041,21.3857997 C89.0844042,21.3857997 91.0846042,23.4735998 91.0846042,26.8169999 C91.0846042,30.1604 89.0844042,32.2482 85.9746041,32.2482 Z M85.9746041,30.321 C87.5952042,30.321 88.5442042,29.0069999 88.5442042,26.8169999 C88.5442042,24.6269998 87.5952042,23.3129998 85.9746041,23.3129998 C84.3540041,23.3129998 83.390404,24.6269998 83.390404,26.8169999 C83.390404,28.9923999 84.3540041,30.321 85.9746041,30.321 Z M93.6250054,32 L95.7274054,32 L95.7274054,24.9335998 C95.7274054,24.5247998 95.6982054,24.1305998 95.6690054,23.7801998 L95.7128054,23.7801998 C95.7420054,24.0575998 95.8296054,24.4955998 95.9318054,24.7729998 L98.1072055,32 L100.180406,32 L102.268206,24.7729998 C102.355806,24.4955998 102.458006,24.0575998 102.487206,23.7655998 L102.531006,23.7655998 C102.487206,24.1597998 102.472606,24.5393998 102.472606,24.9335998 L102.472606,32 L104.721006,32 L104.721006,21.6339997 L101.290006,21.6339997 L99.4650055,27.9557999 C99.3190055,28.4667999 99.2460055,28.8755999 99.2022055,29.2405999 L99.1730055,29.2405999 C99.1292055,28.8755999 99.0708055,28.4813999 98.9248055,27.9849999 L97.0122054,21.6339997 L93.6250054,21.6339997 L93.6250054,32 Z M110.385807,30.175 L110.385807,27.6053999 L114.765807,27.6053999 L114.765807,25.7949998 L110.385807,25.7949998 L110.385807,23.4589998 L115.014007,23.4589998 L115.014007,21.6339997 L107.918407,21.6339997 L107.918407,32 L115.116207,32 L115.116207,30.175 L110.385807,30.175 Z M129.584809,32 L128.796409,29.5763999 L124.971209,29.5763999 L124.182809,32 L121.715409,32 L125.482209,21.6339997 L128.300009,21.6339997 L132.066809,32 L129.584809,32 Z M125.540609,27.8389999 L128.227009,27.8389999 L127.278009,24.9481998 C127.132009,24.4955998 127.000609,24.1013998 126.898409,23.4881998 L126.869209,23.4881998 C126.767009,24.1013998 126.635609,24.4955998 126.489609,24.9481998 L125.540609,27.8389999 Z M143.615412,21.6339997 C145.863812,21.6339997 147.338412,22.9187998 147.338412,24.8897998 C147.338412,26.9483999 145.893012,28.2331999 143.557012,28.2331999 L141.483812,28.2331999 L141.483812,32 L139.016412,32 L139.016412,21.6339997 L143.615412,21.6339997 Z M143.016812,26.5103999 C144.111812,26.5103999 144.754212,25.9409998 144.754212,24.9627998 C144.754212,23.9845998 144.126412,23.4151998 143.016812,23.4151998 L141.483812,23.4151998 L141.483812,26.5103999 L143.016812,26.5103999 Z M155.426813,32 L154.638413,29.5763999 L150.813213,29.5763999 L150.024813,32 L147.557413,32 L151.324213,21.6339997 L154.142013,21.6339997 L157.908813,32 L155.426813,32 Z M151.382613,27.8389999 L154.069013,27.8389999 L153.120013,24.9481998 C152.974013,24.4955998 152.842613,24.1013998 152.740413,23.4881998 L152.711213,23.4881998 C152.609013,24.1013998 152.477613,24.4955998 152.331613,24.9481998 L151.382613,27.8389999 Z M166.391415,21.6339997 L157.908814,21.6339997 L157.908814,23.5903998 L160.916414,23.5903998 L160.916414,32 L163.369214,32 L163.369214,23.5903998 L166.391415,23.5903998 L166.391415,21.6339997 Z M174.538216,32 L172.552616,28.0287999 L171.063416,28.0287999 L171.063416,32 L168.596016,32 L168.596016,21.6339997 L173.151216,21.6339997 C175.779216,21.6339997 176.947216,22.9187998 176.947216,24.8167998 C176.947216,26.1161998 176.261016,27.2111999 174.917816,27.6637999 L177.210016,32 L174.538216,32 Z M171.063416,23.3713998 L171.063416,26.3351999 L172.654816,26.3351999 C173.852016,26.3351999 174.377616,25.7511998 174.377616,24.8167998 C174.377616,23.9115998 173.866616,23.3713998 172.654816,23.3713998 L171.063416,23.3713998 Z M183.955217,32.2482 C180.845417,32.2482 178.845217,30.1458 178.845217,26.8169999 C178.845217,23.4735998 180.845417,21.3857997 183.955217,21.3857997 C187.065017,21.3857997 189.065217,23.4735998 189.065217,26.8169999 C189.065217,30.1604 187.065017,32.2482 183.955217,32.2482 Z M183.955217,30.321 C185.575817,30.321 186.524817,29.0069999 186.524817,26.8169999 C186.524817,24.6269998 185.575817,23.3129998 183.955217,23.3129998 C182.334617,23.3129998 181.371017,24.6269998 181.371017,26.8169999 C181.371017,28.9923999 182.334617,30.321 183.955217,30.321 Z M191.605618,32 L193.868618,32 L193.868618,26.1307998 C193.868618,25.6197998 193.854018,25.1817998 193.854018,24.7583998 L193.883218,24.7583998 C194.014618,25.1379998 194.248218,25.5613998 194.496418,26.0285998 L197.942018,32 L200.570019,32 L200.570019,21.6339997 L198.307018,21.6339997 L198.307018,27.5615999 C198.307018,28.0579999 198.321618,28.4813999 198.321618,28.8901999 L198.292418,28.8901999 C198.161018,28.5105999 197.898218,27.9849999 197.664618,27.5469999 L194.335818,21.6339997 L191.605618,21.6339997 L191.605618,32 Z" id="Become-A-Patron" fill="#FFFFFF"></path> <g id="Patreon-logomark-(color-on-coral)" transform="translate(16.000000, 16.000000)" fill-rule="nonzero"> <path d="M12.5116634,0 C8.36974937,0 5,3.36942158 5,7.51124657 C5,11.6405105 8.36974937,15 12.5116634,15 C16.6407665,15 20,11.6405105 20,7.51124657 C20,3.36942158 16.6407665,0 12.5116634,0" id="Shape" fill="#FFFFFF"></path> <polygon id="Shape" fill="#052D49" points="0 19 4 19 4 0 0 0"></polygon> </g> </g> </g></svg></a> <a class="button--orange" href="https://paypal.me/ghacks" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">Donate via PayPal</a></div></div><aside id="post-author" class='border--top--gray pt--40 mt--40'><div class="profile-content"><h3 class='heading--small mb--20'>About Mike Turcotte-McCusker</h3><div class='user-content'> Mike Turcotte is a Journalism Student at Conestoga College. Mike loves working with Computers in his spare time, focusing on Systems Administration and Programming.</div><div class="profile-link mt--20 user-content"> <a href="https://www.ghacks.net/author/miketur/" data-wpel-link="internal"> View all posts by Mike Turcotte-McCusker <span class="meta-nav">→</span></a></div></div></aside><div class='border--top--gray mt--40 pt--40' id='comments'><h3 class='heading--large'>Comments</h3><ol class="comment-list mt--40"><li class="comment even thread-even depth-1" id="comment-4375161"><div class='comment-item'><div class='comment-item__header opacity--90'><div class='row nocol middle-xs between-xs'><div class='row nocol middle-xs'><div><strong>mungo</strong> said on May 6, 2018 at 2:29 pm</div></div> <a rel="nofollow" class="comment-reply-link" href="#comment-4375161" onclick="return addComment.moveForm( &quot;comment-4375161&quot;, &quot;4375161&quot;, &quot;respond&quot;, &quot;143645&quot; )" aria-label="Reply to mungo" data-wpel-link="internal">Reply</a></div></div><div class='user-content comment-item__content'><p>interdasting</p></div></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="comment-4375199"><div class='comment-item'><div class='comment-item__header opacity--90'><div class='row nocol middle-xs between-xs'><div class='row nocol middle-xs'><div><strong>xplorer</strong> said on May 6, 2018 at 7:09 pm</div></div> <a rel="nofollow" class="comment-reply-link" href="#comment-4375199" onclick="return addComment.moveForm( &quot;comment-4375199&quot;, &quot;4375199&quot;, &quot;respond&quot;, &quot;143645&quot; )" aria-label="Reply to xplorer" data-wpel-link="internal">Reply</a></div></div><div class='user-content comment-item__content'><p>Yes. I use: AsciiDoc, the Asciidoctor ruby gem, Visual Studio Code + AsciiDoc extension + &#8220;Code Spell Checker&#8221; extension.</p></div></div></li><li class="comment even thread-even depth-1" id="comment-4375214"><div class='comment-item'><div class='comment-item__header opacity--90'><div class='row nocol middle-xs between-xs'><div class='row nocol middle-xs'><div><strong>Buzz Buzzard</strong> said on May 6, 2018 at 9:02 pm</div></div> <a rel="nofollow" class="comment-reply-link" href="#comment-4375214" onclick="return addComment.moveForm( &quot;comment-4375214&quot;, &quot;4375214&quot;, &quot;respond&quot;, &quot;143645&quot; )" aria-label="Reply to Buzz Buzzard" data-wpel-link="internal">Reply</a></div></div><div class='user-content comment-item__content'><p>An interesting read. I use LibreOffice Writer almost exclusively, it&#8217;s a great piece of software.</p></div></div></li></ol><div id="respond" class="comment-respond"><h3 class="heading--large mb--20">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/05/06/a-look-at-focuswriter-distraction-free-text-editor-on-gnu-linux/#respond" style="display:none;" data-wpel-link="internal">Cancel reply</a></small></h3><form action="https://www.ghacks.net/wp-comments-post.php" method="post" id="commentform" class="kinsta-form--whitebg kinsta-form" novalidate><p class="comment-form-comment"><label for="comment">Comment</label><textarea required="required" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><div class="row gutter--small mt--20 comment-fields"><div class="col-xs-12 col-sm-6"><p class="comment-form-author"><label for="author">Name</label> <input id="author" required="required" name="author" type="text" value="" size="30" /></p></div><div class="col-xs-12 col-sm-6"><p class="comment-form-email"><label for="email">Email</label> <input id="email" required="required" name="email" type="email" value="" size="30" /></p></div></div><p class='comment-form-subscriptions'><label for='subscribe-reloaded'><select name='subscribe-reloaded' id='subscribe-reloaded'><option value='none' selected='selected'>Don't subscribe</option><option value='yes'>All</option><option value='replies'>Replies to my comments</option> </select> Notify me of followup comments via e-mail. You can also <a href="https://www.ghacks.net/1000/10/1/comment-subscriptions/?srp=143645&amp;srk=9ca44b903ed7f0b8e0eca0781716a751&amp;sra=s&amp;srsrc=f" data-wpel-link="internal">subscribe</a> without commenting.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='143645' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="4e8ef537d1" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="208" /></p></form></div></div></div><div class='ghacks-sidebar'><div id="ghacks_ad_code-2" class="widget ghacks_ad_code mt--30 mt--first--0 ghacks-links--nounderline"><div class='ghacks-ad' data-width='336' data-height='336'> <ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-5406364303442190" data-ad-slot="2528346899"></ins></div></div><div id="search-6" class="widget widget_search mt--30 mt--first--0 ghacks-links--nounderline"><form role="search" method="get" class="search-form" action="https://www.ghacks.net/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form></div><div id="ghacks_share_widget-5" class="widget ghacks_share_widget mt--30 mt--first--0 ghacks-links--nounderline"><h3 class="heading--tiny border--bottom--gray mb--10 pb--6">Spread the Word</h3><div class='row nocol'> <a class="mr--6" href="https://www.facebook.com/ghacksnet" data-wpel-link="external" target="_blank" rel="external noopener noreferrer"><svg class="" style=" " width="48" height="48" viewBox="0 0 48 48" version="1.1"><g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><path d="M44,0 C46.2,0 48,1.8 48,4 L48,44 C48,46.2 46.2,48 44,48 L4,48 C1.8,48 0,46.2 0,44 L0,4 C0,1.8 1.8,0 4,0 L44,0 Z M31,25 L32,20 L27,20 L27,16 C27,14.5 27.8,14 30,14 L32,14 L32,9 L28,9 C23.9,9 21,11.4 21,16 L21,20 L16,20 L16,25 L21,25 L21,39 L27,39 L27,25 L31,25 Z" id="Combined-Shape" fill="#3A5BA0" fill-rule="nonzero"></path></g></svg></a> <a class="mr--6" href="https://twitter.com/ghacksnews" data-wpel-link="external" target="_blank" rel="external noopener noreferrer"><svg class="" style=" " width="48" height="48" viewBox="0 0 48 48" version="1.1"><g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="twitter" fill-rule="nonzero" fill="#2CA7E0"><path d="M44,0 C46.2,0 48,1.8 48,4 L48,44 C48,46.2 46.2,48 44,48 L4,48 C1.8,48 0,46.2 0,44 L0,4 C0,1.8 1.8,0 4,0 L44,0 Z M39,15.2 C37.9,15.7 36.2,16.3 35,16.5 C36.3,15.7 37.5,13.9 38,12.5 C37,13.1 35.9,13.9 34.8,14.3 L34,13.5 C32.9,12.3 31.8,11.5 30,11.5 C26.6,11.5 24,14.1 24,17.5 C24,17.9 24,18.2 24.1,18.5 L24,18.5 C18,18.5 14,17.2 11,13.5 C10.5,14.4 10,15.4 10,16.5 C10,18.6 11.3,20.4 13,21.5 C12,21.5 10.8,21 10,20.5 C10,23.5 14.2,26.9 17,27.5 C16,28.5 12.4,27.6 12,27.5 C12.8,29.9 15.3,31.4 18,31.5 C15.9,33.1 13.4,34 10.5,34 C10,34 9.5,34 9,33.9 C11.7,35.6 15.5,36.5 19,36.5 C30.3,36.5 36,27.6 36,19.5 L36,18.5 C37.2,17.6 38.2,16.4 39,15.2 Z" id="Combined-Shape"></path></g></g></svg></a> <a class="mr--6" href="https://plus.google.com/107836925448900328328/" data-wpel-link="external" target="_blank" rel="external noopener noreferrer"><svg class="" style=" " width="48" height="48" viewBox="0 0 48 48" version="1.1"><g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="googleplus" transform="translate(-27.000000, -16.000000)" fill-rule="nonzero" fill="#E13719"><path d="M71,16 C73.2,16 75,17.8 75,20 L75,60 C75,62.2 73.2,64 71,64 L31,64 C28.8,64 27,62.2 27,60 L27,20 C27,17.8 28.8,16 31,16 L71,16 Z M51,42 C51,42 49,40.8 49,40 C49,40 48.5,38.2 50,37 C51.5,35.8 53,34 53,32 C53,29.7 52,27 50,26 L53,26 L55.4,25 L46,25 C41.8,25 38,28.3 38,32 C38,35.7 40.8,38.6 45.1,38.6 L46,38.6 C45.7,39.1 45.5,39.7 45.5,40.3 C45.5,41.3 46.3,42.3 47,43 L45,43 C39.8,43 36,45.6 36,49 C36,52.4 40.9,55 46,55 C51.9,55 56,52 56,48 C56,45.3 53.5,43.7 51,42 Z M47,38 C44.6,38 41.4,35.1 41,32 C40.6,28.9 42.6,25.9 45,26 C47.4,26.1 49.6,28.9 50,32.1 C50.4,35.2 49,38 47,38 Z M46,53 C42.4,53 39,51.7 39,49 C39,46.3 42.4,44 46,44 L48,44 C49,44 50.9,44.9 52,46 C53,47 53,48.7 53,49 C53,52 51,53 46,53 Z M66,38 L62,38 L62,34 L60,34 L60,38 L56,38 L56,40 L60,40 L60,44 L62,44 L62,40 L66,40 L66,38 Z" id="Combined-Shape"></path></g></g></svg></a> <a href="https://www.ghacks.net/feed/" data-wpel-link="internal"><svg class="" style=" " width="48" height="48" viewBox="0 0 48 48" version="1.1"><g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="rss" fill-rule="nonzero" fill="#F2890A"><path d="M44,0 C46.2,0 48,1.8 48,4 L48,44 C48,46.2 46.2,48 44,48 L4,48 C1.8,48 0,46.2 0,44 L0,4 C0,1.8 1.8,0 4,0 L44,0 Z M14.5,37 C16.4329966,37 18,35.4329966 18,33.5 C18,31.5670034 16.4329966,30 14.5,30 C12.5670034,30 11,31.5670034 11,33.5 C11,35.4329966 12.5670034,37 14.5,37 Z M11,11 L11,15.3 C23,15.3 32.7,25 32.7,37 L37,37 C37,22.6 25.4,11 11,11 Z M11,19.7 L11,24 C18.2,24 24,29.8 24,37 L28.3,37 C28.3,27.4 20.6,19.7 11,19.7 Z" id="Combined-Shape"></path></g></g></svg></a></div></div><div id="text-36" class="widget widget_text mt--30 mt--first--0 ghacks-links--nounderline"><h3 class="heading--tiny border--bottom--gray mb--10 pb--6">Ghacks Newsletter Sign Up</h3><div class="textwidget"><p></p><style type="text/css">#mc_embed_signup{background:#fff;clear:left;font:14px Helvetica,Arial,sans-serif}<br /><br /></style><div id="mc_embed_signup"><form id="mc-embedded-subscribe-form" class="validate" action="https://ghacks.us12.list-manage.com/subscribe/post?u=05d93c4edae4e60daa68c205c&amp;id=dda4c19ba4" method="post" name="mc-embedded-subscribe-form" novalidate="" target="_blank"><div id="mc_embed_signup_scroll"><p><input id="mce-EMAIL" class="email" name="EMAIL" required="" type="email" value="" placeholder="email address" /><br /></p><div style="position: absolute; left: -5000px;" aria-hidden="true"><input tabindex="-1" name="b_05d93c4edae4e60daa68c205c_dda4c19ba4" type="text" value="" /></div><div class="clear"><input id="mc-embedded-subscribe" class="button" name="subscribe" type="submit" value="Subscribe" /></div></div></form></div><p></p></div></div><div id="ghacks_ad_code-3" class="widget ghacks_ad_code mt--30 mt--first--0 ghacks-links--nounderline"><h3 class="heading--tiny border--bottom--gray mb--10 pb--6">Advertisement</h3><div class='ghacks-ad' data-width='336' data-height='336'><div id='div-gpt-ad-1424293853434-0' style='width:300px; height:600px;'> <script type='text/javascript'>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1424293853434-0'); });</script> </div></div></div><div id="ghacks_this_day-4" class="widget ghacks_this_day mt--30 mt--first--0 ghacks-links--nounderline"><h3 class="heading--tiny border--bottom--gray mb--10 pb--6">This Day in History</h3><ul><li><a href="https://www.ghacks.net/2017/05/06/a-look-at-windows-alternatives-in-linux/" data-wpel-link="internal"><strong class='year'>2017</strong> A look at Windows Alternatives in Linux</a></li><li><a href="https://www.ghacks.net/2016/05/06/windows-live-mail-2012-end-of-outlook-support/" data-wpel-link="internal"><strong class='year'>2016</strong> Windows Live Mail 2012 end of Outlook support</a></li><li><a href="https://www.ghacks.net/2015/05/06/mozilla-drops-support-for-binary-components-in-extensions/" data-wpel-link="internal"><strong class='year'>2015</strong> Mozilla drops support for binary components in extensions</a></li><li><a href="https://www.ghacks.net/2014/05/06/duckduckgo-search-engine-launches-redesigned-interface/" data-wpel-link="internal"><strong class='year'>2014</strong> DuckDuckGo search redesign beta now with image and video search</a></li><li><a href="https://www.ghacks.net/2013/05/06/find-out-why-apps-are-incompatible-with-your-android-device/" data-wpel-link="internal"><strong class='year'>2013</strong> Find out why apps are incompatible with your Android device</a></li></ul></div><div id="ghacks_ad_code-4" class="widget ghacks_ad_code mt--30 mt--first--0 ghacks-links--nounderline"><h3 class="heading--tiny border--bottom--gray mb--10 pb--6">Advertisement</h3><div class='ghacks-ad' data-width='336' data-height='336'><div id='div-gpt-ad-1431549664776-0' style='height:250px; width:300px;'> <script type='text/javascript'>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1431549664776-0'); });</script> </div></div></div><div id="ghacks_popular-4" class="widget ghacks_popular mt--30 mt--first--0 ghacks-links--nounderline"><h3 class="heading--tiny border--bottom--gray mb--10 pb--6">Popular Posts</h3><ul><li><a href="https://www.ghacks.net/2018/05/01/all-the-issues-of-windows-10-version-1803-you-may-run-into/" data-wpel-link="internal">All the issues of Windows 10 version 1803 you may run into</a></li><li><a href="https://www.ghacks.net/2018/04/29/re-based-basilisk-browser-released/" data-wpel-link="internal">Re-based Basilisk Browser released</a></li><li><a href="https://www.ghacks.net/2018/03/23/the-future-of-ghacks-2018/" data-wpel-link="internal">The future of Ghacks (2018)</a></li><li><a href="https://www.ghacks.net/2018/04/13/why-im-using-multiple-web-browsers/" data-wpel-link="internal">Why I'm using multiple web browsers</a></li><li><a href="https://www.ghacks.net/2018/03/06/pale-moon-27-8-released/" data-wpel-link="internal">Pale Moon 27.8 released</a></li><li><a href="https://www.ghacks.net/2018/04/02/cloudflare-launches-fast-and-privacy-focused-dns-at-1-1-1-1/" data-wpel-link="internal">Cloudflare launches fast and privacy-focused DNS at 1.1.1.1</a></li><li><a href="https://www.ghacks.net/2018/05/05/here-is-why-you-may-want-to-skip-this-months-windows-updates/" data-wpel-link="internal">Here is why you may want to skip this month Windows Updates</a></li><li><a href="https://www.ghacks.net/2018/03/13/firefox-59-0-release-overview/" data-wpel-link="internal">Firefox 59.0 release overview</a></li><li><a href="https://www.ghacks.net/2018/04/07/microsoft-breaks-disable-web-search-in-windows-10-version-1803/" data-wpel-link="internal">Microsoft broke "disable web search" in Windows 10 version 1803</a></li><li><a href="https://www.ghacks.net/2018/05/02/firefox-60-sponsored-content-for-us-users/" data-wpel-link="internal">Firefox 60: sponsored content for US users</a></li></ul></div><div id="ghacks_ad_code-5" class="widget ghacks_ad_code mt--30 mt--first--0 ghacks-links--nounderline"><h3 class="heading--tiny border--bottom--gray mb--10 pb--6">Advertisement</h3><div class='ghacks-ad' data-width='336' data-height='336'><div id='div-gpt-ad-1431549718596-0' style='height:250px; width:300px;'> <script type='text/javascript'>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1431549718596-0'); });</script> </div></div></div><div id="ghacks_last_updated-2" class="widget ghacks_last_updated mt--30 mt--first--0 ghacks-links--nounderline"><h3 class="heading--tiny border--bottom--gray mb--10 pb--6">Recently Updated</h3><ul><li><a href="https://www.ghacks.net/2011/01/08/torchat-decentral-anonymous-instant-messenger/" data-wpel-link="internal">TorChat, Decentral Anonymous Instant Messenger</a></li><li><a href="https://www.ghacks.net/2018/05/05/here-is-why-you-may-want-to-skip-this-months-windows-updates/" data-wpel-link="internal">Here is why you may want to skip this month Windows Updates</a></li><li><a href="https://www.ghacks.net/2018/05/04/use-findstr-on-windows-to-find-text-in-files-and-elsewhere/" data-wpel-link="internal">Use findstr on Windows to find text in files and command outputs</a></li><li><a href="https://www.ghacks.net/2018/05/04/how-to-change-your-twitter-password/" data-wpel-link="internal">How to change your Twitter password</a></li><li><a href="https://www.ghacks.net/2018/05/04/firefox-downloads-highlighted-on-new-tab-page/" data-wpel-link="internal">Firefox: Downloads highlighted on New Tab Page</a></li><li><a href="https://www.ghacks.net/2018/05/01/all-the-issues-of-windows-10-version-1803-you-may-run-into/" data-wpel-link="internal">All the issues of Windows 10 version 1803 you may run into</a></li><li><a href="https://www.ghacks.net/2018/05/03/spectre-next-generation-vulnerabilities/" data-wpel-link="internal">Spectre Next Generation vulnerabilities affect Intel processors</a></li><li><a href="https://www.ghacks.net/2011/03/06/how-to-edit-reset-the-windows-hosts-file/" data-wpel-link="internal">How To Edit, Reset The Windows Hosts File</a></li><li><a href="https://www.ghacks.net/2016/08/08/10-ways-to-free-up-hard-drive-space-on-windows/" data-wpel-link="internal">10 Ways to free up hard drive space on Windows</a></li><li><a href="https://www.ghacks.net/2018/05/02/microsoft-office-may-2018-non-security-updates-overview/" data-wpel-link="internal">Microsoft Office May 2018 non-security updates overview</a></li></ul></div><div id="text-35" class="widget widget_text mt--30 mt--first--0 ghacks-links--nounderline"><div class="textwidget"></div></div></div></div></div><div class='mt--30' id='site-footer'><div class='bg--darkGray color--white pt--40 pb--40'><div class='container'><div class='row gutter--large'><div class='col-xs-12 col-sm-6'><h4 class='heading--tiny mb--10'>About gHacks</h4><p class='text--small'> Ghacks is a technology news blog that was founded in 2005 by Martin Brinkmann. It has since then become one of the most popular tech news sites on the Internet with five authors and regular contributions from freelance writers.</p></div><div class='col-xs-12 col-sm-3 ghacks-links--nounderline mt--xs--40'><ul class='top-level'><li> <a href="https://www.ghacks.net/contact/" data-wpel-link="internal">Contact</a></li><li> <a href="https://www.ghacks.net/about-us/" data-wpel-link="internal">About</a></li><li> <a href="https://www.ghacks.net/disclaimer/" data-wpel-link="internal">Disclaimer</a></li><li> <a href="https://www.ghacks.net/ghacksnet-feed-list/" data-wpel-link="internal">RSS Feeds</a></li><li> <a href="https://www.ghacks.net/privacy-policy/" data-wpel-link="internal">Privacy Policy</a></li><li> <a href="https://www.ghacks.net/we-use/" data-wpel-link="internal">We Use</a></li></ul></div><div class='col-xs-12 col-sm-3 ghacks-links--nounderline mt--xs--40'><ul class='top-level'><li> <a href="https://www.ghacks.net/author/martin/" data-wpel-link="internal">Martin Brinkmann</a></li><li> <a href="https://www.ghacks.net/author/miketur/" data-wpel-link="internal">Mike Turcotte</a></li></ul></div></div></div></div><div class='bg--black color--white pt--6 pb--6 text--center'><div class='container'><div class='opacity--60 text--tiny'>&copy; 2018 gHacks Technology News. All Rights Reserved.</div></h4></div></div><link rel='preload' id='bsf_style-css' href='https://www.ghacks.net/wp-content/cache/min/1/wp-content/plugins/all-in-one-schemaorg-rich-snippets/css/style-e7b00a1f37b8b171d90909827fc31bcf.css' as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" type='text/css' media='all' /> <script type='text/javascript'>/* <![CDATA[ */ var cnArgs = {"ajaxurl":"https:\/\/www.ghacks.net\/wp-admin\/admin-ajax.php","hideEffect":"fade","onScroll":"no","onScrollOffset":"100","cookieName":"cookie_notice_accepted","cookieValue":"TRUE","cookieTime":"2147483647","cookiePath":"\/","cookieDomain":"","redirection":"","cache":"1"}; /* ]]> */</script> <script type='text/javascript' src='https://cdn.ghacks.net/wp-content/cache/busting/1/wp-content/plugins/cookie-notice/js/front.min-1.2.42.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var ghacks = {"adBlockerMessage":"Using an Ad Blocker? We hate ads too, why not support us with <a href=\"https:\/\/www.patreon.com\/bePatron?c=150037\" rel=\"nofollow\">Patreon<\/a> or a <a href=\"https:\/\/paypal.me\/ghacks\" rel=\"nofollow\">PayPal donation<\/a> so that we can get rid of these altogether?"}; /* ]]> */</script> <script type='text/javascript' src='https://cdn.ghacks.net/wp-content/cache/busting/1/wp-content/themes/new-ghacks-preview/scripts-1525651200.js' defer></script> <script type='text/javascript' src='https://cdn.ghacks.net/wp-content/cache/busting/1/wp-content/themes/new-ghacks-preview/mar-1525651200.js' defer></script> <script type='text/javascript' src='https://cdn.ghacks.net/wp-includes/js/comment-reply.min.js' defer></script> <script async="async" type='text/javascript' src='https://cdn.ghacks.net/wp-content/cache/busting/1/wp-content/plugins/akismet/_inc/form-4.0.3.js'></script> <div id="cookie-notice" role="banner" class="cn-bottom bootstrap" style="color: #fff; background-color: #000;"><div class="cookie-notice-container"><span id="cn-notice-text">We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.</span><a href="#" id="cn-accept-cookie" data-cookie-set="accept" class="cn-set-cookie button bootstrap" data-wpel-link="internal">Ok</a></div></div><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>jQuery('.adsbygoogle').each(function(){
    (adsbygoogle = window.adsbygoogle || []).push({});
});</script> <noscript><link rel='stylesheet' id='cookie-notice-front-css'  href='https://cdn.ghacks.net/wp-content/plugins/cookie-notice/css/front.min.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='wprc-style-css'  href='https://www.ghacks.net/wp-content/cache/min/1/wp-content/plugins/report-content/static/css/styles-d7bb4f907a97ce82b6e0e6e6910286d8.css' data-minify="1"  type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='dlm-frontend-css'  href='https://www.ghacks.net/wp-content/cache/min/1/wp-content/plugins/download-monitor/assets/css/frontend-b261307d89a4e14e8effccc50a11e4ff.css' data-minify="1"  type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='ghacks-style-css'  href='https://www.ghacks.net/wp-content/cache/min/1/wp-content/themes/new-ghacks-preview/style-5685282605538f241454946a138b2caf.css' data-minify="1"  type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='rating_style-css'  href='https://www.ghacks.net/wp-content/cache/min/1/wp-content/plugins/all-in-one-schemaorg-rich-snippets/css/jquery.rating-267b5ea18d0f55da804ae9be29304802.css' data-minify="1"  type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='bsf_style-css'  href='https://www.ghacks.net/wp-content/cache/min/1/wp-content/plugins/all-in-one-schemaorg-rich-snippets/css/style-e7b00a1f37b8b171d90909827fc31bcf.css' data-minify="1"  type='text/css' media='all' /></noscript></body></html>
