Fix Feedburner Not Updating RSS News Feed - gHacks Tech News

Fix Feedburner Not Updating RSS News Feed

Okay I spend most of the weekend trying to find out why my RSS news feed was not displaying for many of my readers, and why I would get all kinds of errors like 404 not found in the beginning and then a dubious homepage when opening the RSS News Feed url in the browser.

I had a lively email conversation with Google support which helped a bit but not much.

I figured it out by myself just a few minutes ago. Here is what I did. My Feedburner feed was being transferred from Feedburner to Google and I had to change a cname entry to reflect that change.

Everyone knows that changes to the DNS can take up to 48 hours and I first thought that this was the issue.

feedburner issue

Other webmasters on various forums reported similar problems, especially those dreaded 404 not found problem. Once the 404 went away I encountered the main problem. The feed was not showing up. When I opened it in the browser it would simply show the Ghacks homepage.

Google support told me to change the url in the Feedsmith WordPress plugin to the new feedproxy url which I did. This did not turn out to fix the initial problem though.

I opened http://feedburner.google.com/, went to the Troubleshootize tab and tried to Resync my feed.

Thought that this could be the problem. The resync basically told me that it could not find a feed and that I should check the original feed url at Feedvalidator.

I checked it there and it told me that this was not a valid RSS News Feed. The old url which was entered in Feedburner from day 1 was https://www.ghacks.net/?feed=rss2. You can check that for yourself if you click on the Edit Feed Details tab.

I changed the feed to https://www.ghacks.net/feed which turned out to be a valid feed. The last step was to enter that feed url into the Original Feed option on the Google Feedburner site. I tried to sync the feed and that worked as well. I went to Google Reader and updated my feed and wham, there were all my missing posts.

If you have a similar problem I suggest you check out if your feed in Feedburner ends with ?feed=rss2 or something similar. Check that at Feedvalidator and try other feed urls if the first comes up as no valid RSS News Feed.

Please let me know if you can access my feed properly now. I would also like to hear from other webmasters with the problem.

Summary
Fix Feedburner Not Updating RSS News Feed
Article Name
Fix Feedburner Not Updating RSS News Feed
Description
The guide describes how you may resolve a issue with the feed distribution service Feedburner if it throws error messages or does not show the feed.
Author
Publisher
Ghacks Technology News
Logo




  • We need your help

    Advertising revenue is falling fast across the Internet, and independently-run sites like Ghacks are hit hardest by it. The advertising model in its current form is coming to an end, and we have to find other ways to continue operating this site.

    We are committed to keeping our content free and independent, which means no paywalls, no sponsored posts, no annoying ad formats (video ads) or subscription fees.

    If you like our content, and would like to help, please consider making a contribution:

    Comments

    1. Steve DeWitt said on August 26, 2008 at 1:17 am
      Reply

      Martin,

      Doesn’t seem like your problem is completely fixed after all. Why? I just tried to subscribe to this RSS feed using your hot link above and then I clicked on the Bloglines icon (which is the reader I use) and it came back in Bloglines saying there was no valid Rss feed there.

      So your feed can’t be subscribed to because the readers still don’t think it is a valid feed.

      Hope this helps you trouble shoot some more
      8/25/08

    2. -=Ben=- said on August 26, 2008 at 1:35 am
      Reply

      Confirmed, Fixed!

      BTW:
      I use the Firefox Extension “Brief RSS Reader” to aggregate my feeds

    3. archer said on August 26, 2008 at 1:35 am
      Reply

      using sage, yours, and others, have been hit and miss, working sometimes, not others. just now your feeds are loading–no “url parse error” notice–but the most recent item displaying is “perspectives…”

    4. Rarst said on August 26, 2008 at 7:51 am
      Reply

      I am sooo waiting on this transfer. :) They said they are transferring everyone in the end so why bother with manual transfer and make yourself willing beta-tester?

    5. Martin said on August 26, 2008 at 9:46 am
      Reply

      I check that out guys. It seems that feed updates get delayed and only god knows why.

      Rarst, sometimes, I’m stupid ;)

    6. Jojo said on August 26, 2008 at 11:40 pm
      Reply

      I had a problem with this feed for 2 or 3 days prior in Bloglines. Updates weren’t coming in and Bloglines had a red exclamation point next to the feed.

      When this happens, the solution in in Bloglines is to unsubscribe to the feed and then resubscribe. After doing this, everything seems to be back to normal now (but I have 24 posts to plow through).

      btw: If you do this unsubscribe/subscribe in Bloglines and you have marked posts to be kept, you need to first save those posts (use the “clip/blog this” entry at the end of each post). If you do not do this, you will lose all your saved posts when you unsubscribe!

    7. Roman ShaRP said on August 27, 2008 at 12:35 am
      Reply

      I hadn’t any problems accessing Ghacks via RSS.

    8. Triandafilos Tsouridis said on September 30, 2008 at 4:33 am
      Reply

      after upgrading worpress in Aug i found my feed were not working and dont know how i can fix em.. feedburner says feed cannot be found now..! Please help i dont know where to turn..
      Thanks Phillip here it is.. http://www.desiregoji.com/pizzaequipment/feed/

    9. Dionne said on April 28, 2010 at 9:18 pm
      Reply

      I’ve accidentally deleted my feed on feed burner, do you have any suggestions on what I can possibly do to fix this? I would appreciate any help you can give me!!

    10. Jon Galloway said on January 14, 2012 at 9:21 pm
      Reply

      I didn’t want to have to choose between reducing the number of posts or switching to summaries – so I wrote a little plugin that shows full text for recent posts (50, configurable) and summary for old posts. Might help people out – I wished there was something like that when I kept running into this problem. It’s called Excerpt Old Posts, you can find it in the plugin directory or here: http://wordpress.org/extend/plugins/excerpt-old-posts/

    Leave a Reply